GO 620 starts to do unexpected Blackouts

AlFu
AlFu Registered Users Posts: 40
Master Explorer
Recently, on the final approach to an important appointment, the Screen showed the TomTom Logo and within 3 Seconds shut down. Nothing could wake it up again, power unplug, replug, press button ... it stayed dark. So we stopped at the roadside, and after a few minutes it booted up again. We continued driving, and after 5 minutes again the same, it showed for a very brief moment the TomTomLogo and went black. No time so we went on with Google Maps on our Mobile. Today again, I drive and same scenario, Screen turns black, TomTom Logo flashes and it dies. After a few kilometer "unsafe driving" as one hand is fiddling with the TomTom GO 620, it started again, booted up and continued.
Can somebody tell me what is going wrong with this Device? I mean I thought I "upgraded" from a GO 600 to the new GO 620, but feel the hardware is the same sluggish and now the GO 620 even becomes unreliable. I use it with NO Memory Card. I checked and the USB Power Supply is fine. Any advise please? I feel it all started after I installed the TomTom App on my Mobile.
Tagged:

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,306
    Revered Voyager
    Battery problem?
    Check that your cable or the cigarette lighter charger is not faulty.
  • DougLap
    DougLap Posts: 9,817
    Superuser
    Hi @AlFu

    Are you using the supplied supplied Cig Charger or are you connecting the USB cable to a USB socket on the car. If the latter then the power supplied by the USB socket will not be sufficient to run and maintain battery level as the USB socket is generally designed for Data not power.

    Doug
  • AlFu
    AlFu Registered Users Posts: 40
    Master Explorer
    Your answer is interesting. I use the same power supply for years for my TomTom (first the 600 and now at the 620) and all of a sudden it is not sufficient? Makes not much sense, as I have checked the power outlet and that is as good as it always was, see no reason why that capacity should suddenly change.

    Have it now connected to a desktop USB Charger, and after 30 min it is still as much as dead. It was working earlier when I drove to the shopping centre, but when I left the shopping centre the TomTom was as dead. Have to search how to get a possible support from TomTom to this issue.
  • AlFu
    AlFu Registered Users Posts: 40
    Master Explorer
    Please do not make proposals that look like you are paid by posting.

    I have a TomTom for many years and know how to check a cable and I use a dedicated USB Source only for the TomTom. And as it seems to work occasionally normal (between the first posting above and the posting today I even ran once an update of the TomTom to the latest Maps etc), I have no idea what the issue is. An internal contact loose or a soldering point bad. Because if it were plainly the battery, it should come alive after 30 min on a USB Desktop Charger?

  • AlFu
    AlFu Registered Users Posts: 40
    Master Explorer
    I do have the feeling the troubles with the GO620 started after I followed the advice to install an app on my Mobile to have Phone calls etc going via the GO620. It was working well before that time. I will uninstall anything TomTom on my mobile, but have to see first whether the GO620 comes alive at all again.

    As far as contacting TomTom for support is concerned, I have the impression there is nothing of any kind of professional support. At least I could not find any so far. And if this turns out to be an "unsupported product" then it will be impossible to get future budget for such equipment.
  • YamFazMan
    YamFazMan Posts: 20,785
    Superuser
    edited February 2
    Hi
    @AlFu
    Contacting Tomtom Support….
    Due to COVID-19 & Staff working from home….
    The phone service has been suspended (Indefinitely)

    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    Chat… Will be available during Normal Office Hours
    Email… Will be available outside of Normal Office Hours

    Step by step tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1771083/#Comment_1771083

    _________________________
    End
    _________________________

    There's an unresolved problem with the Apple iPhone iOS 13 and above, and the Tomtom 'MyDrive App' advanced Smartphone features....
    If you can live without the advanced Smartphone features (i.e... Smartphone Messaging)
    Just use a straight simple Bluetooth Connection....

    Some tips you may want to see/try....
    Here... https://discussions.tomtom.com/en/discussion/comment/1741299/#Comment_1741299

    Stay Safe... ATB YFM
  • AlFu
    AlFu Registered Users Posts: 40
    Master Explorer
    Dear YamFazMan

    Thanks for your kind advice.

    To my surprise, the GO620 came alive again. I unplugged it and pressed the power switch and it booted up. I did the same earlier in the car already, but at that time no response.
    I use it with Android Phones. But as said earlier, I do have the impression troubles started with me following the setup recommendation for, I can't remember now, it was in the car with the phone with me, and it was either Bluetooth or Wifi I had to accept, since then telephone calls go to the GO620 when I am in the car, but since then it also starts to fail completely for a period of 1 to 2 hours. It fails without any prior warning. Like before, when I left the car in the carpark, the GO620 was shutting down normally (when I cut the power supply it goes into standby after 12 or so seconds). But normally when I start the car, it starts up again. Only before it did not. Quite disturbing.
    I like the TomTom but am under pressure of my younger family members who find it disturbing if such device is not reliably working. If it fails, first I check the power outlet, ok fine, works with phone (I assume my smartphone draws more power than the GO620). Next I take the GO620 out of it's windows holder and plug the USB connector directly into the GO620 to eliminate any "error" due to the contacts in the wall holder. No change. Then I press the power button for 30 sec ... no change, then I unplug and press ... no change ... then I replug and press ... nothing .... then I start up Google Maps and my daughter asks me why I went through the GO620 hazzle in the first place. I really would appreciate it to be reliably working ;)

    Thanks for your info, will see if I find somebody at TomTom to help to sort this out.