I bought "Live Services", got an acknowledgement, "Speed Cameras" delivered.

Sordyste
Sordyste Registered Users Posts: 10
Apprentice Seeker
edited January 4 in TomTom Services
On 1st Jan'22, I bought "Live Services -World" (only needed Europe but not available). I received an email acknowledgement from TomTom that clearly stated it was "Live Services - World". But when I went to download via My Drive Connect, what was waiting for me was "Speed Cameras- World". I cannot find a way to contact TomTom directly to query this and as for the support pages and the chat boxes... Let's say that I have not found the correct combination of words to get an answer yet. It is now 4th Jan and I need some new ideas on how to contact TomTom or at least someone to tell me that "Live Services" is embedded inside "Speed Cameras" and it's fine to download it. I would really appreciate some assistance, please. :)

Best Answer

  • Willy875
    Willy875 Registered Users Posts: 6,640
    Elite Voyager
    Answer ✓
    Delete your cookies or change browser.

Answers

  • Willy875
    Willy875 Registered Users Posts: 6,640
    Elite Voyager
    To contact customer service

    How to contact TomTom customer support by chat or email
    https://help.tomtom.com/hc/en-gb/articles/360015568919/

    How to contact TomTom customer support by email
    https://help.tomtom.com/hc/en-gb/requests/new?ticket_form_id=360000679560


    Be careful if you have been without a traffic subscription for more than 18 months, your Sim card has been deactivated.
  • Sordyste
    Sordyste Registered Users Posts: 10
    Apprentice Seeker
    Thank you Willy875. That was swift! :)

    I have tried both those links, but they bring me straight back to the Discussion Forum. A page that appears to be what you intended opens very briefly (like half a second) before shifting to the discussion pages. The shift is so rapid that I have no time to actually do anything. Any other suggestions will be gratefully received. :)

    PS: Unpaid or lapsed traffic subscription is not a problem.
  • Willy875
    Willy875 Registered Users Posts: 6,640
    Elite Voyager
    Answer ✓
    Delete your cookies or change browser.
  • Sordyste
    Sordyste Registered Users Posts: 10
    Apprentice Seeker
    Thanks again Willy875, deleting my cookies did the trick. I have emailed TomTom and they have acknowledged it and will "get back to me soon".

    To get to this stage has taken almost 4 days. Why do TomTom make it so hard? It was YOU that helped me, not TomTom. Thanks again. :)

    Have a Good New Year.