Go premium 6 - traffic alerts not working — TomTom Discussions

Go premium 6 - traffic alerts not working

GG1234
GG1234 Registered Users Posts: 4
Apprentice Traveler
Need help, I have a Go premium 6 and even though on the device it says traffic alert activated I have never got any traffic alerts. Any idea why and what I need to do to get it working? Cheers

Best Answer

  • GG1234
    GG1234 Registered Users Posts: 4
    Apprentice Traveler
    Accepted Answer
    Thanks Vikram for checking.

    The webchat device assistant said to do a soft reset factory reset, just did and for the first time I see traffic!

    Thanks again

Answers

  • YamFazMan
    YamFazMan Posts: 20,479
    Superuser
    Hi
    @GG1234
    Welcome to the site....


    GPRS SIM connection on the Tomtom Live devices....
    There are 3 Data connection options that can have a higher/priority/override the Built-in GPRS SIM....

    To check the Data Connection status....
    Tap 4Dot (.... Menu) --> Setting --> System --> About…
    Scroll down to Data Connection & GPRS Status....
    What does the device report...???
    Is the GPRS Status... Connected ???
    _________________________

    (1).... An active USB connection on your PC + MyDrive connect running on your PC....

    Check the GPRS SIM Data Connection....
    Are you at home with your GO Premium connected to a USB port on your PC for a power supply + MyDrive connect running on your PC ???
    The USB connection will take priority over the GPRS SIM....

    Disconnect the USB Lead from your PC....

    Note... If you need to power the device, when checking the GPRS SIM Connections, use something like a Mains USB Charger or a SmartPhone USB charger with the original Tomtom Power lead....
    _________________________
    _________________________

    (2)... Bullet point (2) only applies to the latest Wi-Fi Connected devices....
    An active Wi-Fi connection on your Tomtom device...
    .
    With your device still disconnected from USB....
    Turn off Wi-Fi....
    Wi-Fi will take priority over the GPRS SIM
    Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on your Connected Wi-Fi
    Tap (Modify) Icon
    Tap (Forget) Icon
    To verify the Wi-Fi is OFF Tap 4Dot (.... Menu) screen top right Wi-Fi logo with X
    70e5b90b-25ce-4fca-994c-e836a17cb9fa.jpg

    Note....
    To Reconnect to Wi-Fi....
    Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on your chosen Wi-Fi
    Enter your Wi-Fi Password
    Tap Done
    Tap Connect

    Note... I find the Wi-Fi devices are more stable and more responsive in general use when you 'Forget' the Wi-Fi connection....
    Unless you're using a personal My-Fi Hotspot in the car for your data connection, the only other reason for a live Wi-Fi connection is for updating the device....
    I always turn off (Forget) the Wi-Fi by default and only login for updates....
    It's no big deal for updates, you only have to enter your Wi-Fi password
    _________________________
    _________________________

    On Tomtom NAV4 & (Wi-Fi) connected devices...
    With a built-in GPRS SIM....
    (3)... An active Bluetooth/phone connection.... 'Data for Traffic & other services' set to ON when using the MyDrive App on a Tomtom Live device ???

    Is your iPhone connected over Bluetooth to the MyDrive App....
    If you have selected the 2nd Bluetooth option....
    'Data for Traffic & other services' ON.....
    The Bluetooth/Phone connection will have priority over the GPRS SIM....

    dtsfwp43pa9e.jpg

    wkkikyhv4wmt.jpg

    See.... https://discussions.tomtom.com/en/discussion/comment/1745255/#Comment_1745255
    __________________________

    Also, See... The following post....
    There's an unresolved problem with the Apple iPhone iOS 13 & 14 the MyDrive App and the advanced Smartphone features....

    Stay Safe... ATB YFM
  • GG1234
    GG1234 Registered Users Posts: 4
    Apprentice Traveler
    Thanks VanFazMan for your response and the welcome comment.

    I'm indoors presently with device. I have turned off WIFI and GPRS status is showing as connected. I normally leave the WIFI connected as I thought when out of range it would automatically connect to GPRS? Or do I have to keep turning of the wifi?

    Traffic shows as activated on the device.

    Also as I've never seen any traffic alerts and have been using this device for a few months. I just want to check is it like Google maps, should I see red on the road maps showing heavy traffic and warning alerts come up if any accidents road closures etc? As I've never seen any of this with my Tom Tom.
    Thanks again for your help.
  • DougLap
    DougLap Posts: 9,377
    Superuser
    Hi @GG1234

    Yes the unit should auto switch to the Inbuilt Mobile Sim once you are out of range of the Wifi you are connected too so. To check connect to Wifi then keep walking away.

    Maybe useful to have @VikramK check your units settings on the TT servers. Look back here later to see what he says.

    Doug
  • GG1234
    GG1234 Registered Users Posts: 4
    Apprentice Traveler
    Hi Doug,

    Thanks yes checked it does auto switch in the inbuilt mobile sim when out of range of WiFi. Just never seen any traffic alerts! Was on the M4 yesterday and nothing...

    Will wait to see what @VikramK says about the unit settings on the IT servers

  • DougLap
    DougLap Posts: 9,377
    Superuser
    Hi @GG1234

    Thanks so now see what @VikramK has to say after he has checked your units settings on the TT servers.

    Doug
  • VikramK
    VikramK Registered Users, Administrators Posts: 13,074
    Moderator
    Hi @GG1234
    The subscriptions for your TomTom look okay. The connectivity issue could perhaps be related to the SIM.
    Could you please report this to our customer service team to review the SIM status and advise accordingly?
    https://help.tomtom.com/hc/en-gb/articles/360015568919/

    Thank you
    Vikram
  • GG1234
    GG1234 Registered Users Posts: 4
    Apprentice Traveler
    Accepted Answer
    Thanks Vikram for checking.

    The webchat device assistant said to do a soft reset factory reset, just did and for the first time I see traffic!

    Thanks again