Cant Delete Maps on GO5200

RobFJ
RobFJ Registered Users Posts: 16
Apprentice Traveler
edited December 2021 in Devices using Wi-Fi®
I've two Europe map files - 15000M in combined size and they take forever to update. As I don't need them and dont want the continual reminder to update message I want to delete them.

However when I go to "Remove Content From Your Device" in MyDriveConnect on my PC I can get to a window "Free Up Space on your Device", I can click the items I want to delete, scroll to the bottom and click "Delete Selected". Then nothing happens.

Essentially all I want to be left with on my SatNav is the UK and Ireland map (+ saved info on destinations, etc.) with all other entries on the Free Up Space window (countries and people) deleted.

Can someone help please.

OS is windows. My Drive Connect is v 4.2.12.4208


Answers

  • DougLap
    DougLap Posts: 10,029
    Superuser
    Hi @RobFJ

    What happens if whilst not connected to the PC you go to Settings/Maps on the GO5200 and select Delete a Map?

    Doug
  • RobFJ
    RobFJ Registered Users Posts: 16
    Apprentice Traveler
    Hi @DougLap

    I get a message "Oops Something went wrong. Please try again." if I try to delete the Europe Map. (UK and RoI being the default map.)

    For info, I tried to upgrade the Europe map to see what happpened - I got the same error message.

    Robin
  • boronczyk.bartosz_un38
    boronczyk.bartosz_un38 Registered Users Posts: 5
    Master Traveler
    I'm getting same message all the time trying to update, add or delete anything from my 5200 firstly he loading wheel spins for 5 minutes and then ....Oops Something went wrong. Please try again. I've tried connecting with USB cable, two different WIFI networks ... same message.. App version 21.20.0003.411 maps v1085.11320 free space 2.13GB.
    Keeps showing available updates but unable to do anything .
  • boronczyk.bartosz_un38
    boronczyk.bartosz_un38 Registered Users Posts: 5
    Master Traveler
    I've just found the way of getting 5200 out of update loop. It kept updating itself starting from 70% up to 98% and back to 70. Firstly it wouldn't even start updating. Resetting the device connecting to my drive on laptop did not help at all. Tried everything. Different logins, different WiFi networks. It just got stuck on update. Satnav was fully functional when out of the range of WIFI but as soon as it tried to update / connected to pc or WiFi it got stuck.
    Now my way around the problem was another factory reset followed by setting it up in different country and then it actually allow me to delete maps cleared all incomplete downloads (think that what happened) and then it still started with unfinished download 70% but when got to 98 it reset itself and started from 0% - at this point I knew it will work again. So changing initial system language and region cleared / or helped with the update problem. Might not be suitable for this problem but hopefully will help anyone else who got his 5200 in update loop ( it was speed camera update that was failing btw)