Adding Speedcameras?

DJSheridan
DJSheridan Registered Users Posts: 128
Sovereign Trailblazer
edited December 2021 in Devices using Wi-Fi®
I have a Premium X...
Now since having this device it does not show up mobile speed cameras.
I have used the Speed Camera icon to add them but it only seems to add in fixed cameras. I am pretty sure my old device 5200 used to allow me to select the type - but this one doesn't.

Why is this?

I have tried to add in some local mobile cameras but it won't let me.
Tagged:

Answers

  • Willy875
    Willy875 Registered Users Posts: 6,523
    Elite Voyager
    For mobile speed cameras, several users must report this speed camera for the speed camera to report a certain time on the device.
  • DJSheridan
    DJSheridan Registered Users Posts: 128
    Sovereign Trailblazer
    Sort of answers the question - but seems they do not believe us when we say they are there - so does not help others out.
    Strange thing is they used to be there on the database and even though they are physically there they have been removed.
    I feel that some users are too trigger happy to click on 'No' to "Is this camera still here" instead of leaving it - as we all know these cameras are not there 24/7... but they will be back.
  • YamFazMan
    YamFazMan Posts: 21,141
     Superuser
    Hi
    @DJSheridan
    For general improvement using the Tomtom Speed Cam Database over the default settings....
    See... https://discussions.tomtom.com/en/discussion/comment/1765701/#Comment_1765701

    Stay Safe... ATB YFM
  • DJSheridan
    DJSheridan Registered Users Posts: 128
    Sovereign Trailblazer
    Done all of that previously... but still have issues.

    Looks like I'm having to reset my device yet again as nobody can come up with a cast-iron answer to this.
    My old device I never had any issues - but with this Premium X I have had problem after problem.
    Waste of money and Tom Tom are not offering any support as the contact does not work as it keeps refreshing to the forums.
  • YamFazMan
    YamFazMan Posts: 21,141
     Superuser
    edited November 2021
    Hi
    @DJSheridan
    Speed Cams Working OK on my GO Premium....
    The fixed Speed camera database is fairly static, but the Mobile locations change day by day, even hour by hour at the various locations....
    I travel the A49 into Worcester most days, there were 2 fixed cameras plus a Mobile camera van using multiple locations.... recently there has been a change, now some-of the route is covered by Average speed zones....
    The Tomtom Speed Cam database has kept up-to-date with all the changes... :)

    ATB YFM