Maps do not appear

Maureen_Denny68
Maureen_Denny68 Registered Users Posts: 6
Apprentice Seeker
I have purchased a GO Supreme because of the map coverage that was supposed be included. https://promotion.tomtom.com/en_au/replacement-offer/?prefix=W8

The only maps installed on this device are the Australia, New Zealand, Oceania, etc maps. I have gone into settings to Add A Map, looking for European maps, France and the UK specifically, and there is nothing coming up. It doesn't even give me an option to find them.

Where am I going wrong?

Help!

Best Answer

  • VikramK
    VikramK Administrators Posts: 13,744
    Moderator
    Answer ✓
    Hi Maureen
    I’m glad to hear you got it sorted! :D

    When you're satisfied that your question has been answered, please mark your topic as solved so that others with a similar question may find the answer easier.

    If you have further questions, don't hesitate to post back here.

    Thanks,
    Vikram

Answers

  • DougLap
    DougLap Posts: 9,831
    Superuser
    Hi @Maureen_Denny68

    You are doing nothing wrong I suspect. It would appear that your unit has not set itself up fully on the TT servers. Look back here later tomorrow to see what @VikramK or @lampard have to say after they have reviewed the units TT server settings and change if required.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,744
    Moderator
    Hi @Maureen_Denny68
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram
  • Maureen_Denny68
    Maureen_Denny68 Registered Users Posts: 6
    Apprentice Seeker
    Thank you Vikram. I will give this a try.
  • Maureen_Denny68
    Maureen_Denny68 Registered Users Posts: 6
    Apprentice Seeker
    Hi Vikram.

    I am not getting anywhere!

    I have reset my device.

    I have uninstalled and re-installed MYDRIVECONNECT because my TOMTOM account did not show my new device as being connected to my account.

    I logged in on both my computer and the TOMTOM device.

    All that shows in MYDRIVECONNECT is the ongoing popup box telling me to log-in, repeatedly. This is all it has MYDRIVECONNECT has ever done in the past so I thought it was the device itself that was the problem.

    On the device, it says I am logged in and all updates are current. And I still only have Australia, Oceania, etc maps.

    Maybe the problem is the MYDRIVECONNECT?

    I am getting so frustrated by this as TOMTOM was always so easy to use before.

    Not sure what to try now.

    Regards
    Maureen
  • VikramK
    VikramK Administrators Posts: 13,744
    Moderator
    edited November 2021
    @Maureen_Denny68
    Hi Maureen
    I have linked the device to your TomTom account.
    The device comes with pre-installed regional maps. To install other map regions, you can try connecting the device to a WiFi internet and add Maps.

    Main menu > Settings > Maps > Add a Map

    Select the map region you wish to install > tap on 'Download'

    Regards
    Vikram.
  • Maureen_Denny68
    Maureen_Denny68 Registered Users Posts: 6
    Apprentice Seeker
    Success! I have been able to access the maps via WiFi.
    Thank you for all your assistance.
    Maureen
  • VikramK
    VikramK Administrators Posts: 13,744
    Moderator
    Answer ✓
    Hi Maureen
    I’m glad to hear you got it sorted! :D

    When you're satisfied that your question has been answered, please mark your topic as solved so that others with a similar question may find the answer easier.

    If you have further questions, don't hesitate to post back here.

    Thanks,
    Vikram