Yearly subscriptions not working!

Ciderboy
Ciderboy Registered Users Posts: 2
Novice Seeker
Hi,
I have just recently purchased yearly subscriptions for both live traffic and camera updates for my Go6200 (Sunday) , but as yet they have not shown to be working. I have done both soft and factory resets, but still nothing. TIA

Answers

  • DougLap
    DougLap Posts: 9,860
    Superuser
    edited November 2021
    Hi @Ciderboy

    Assuming the unit is not a GO6200 Professional why are you buying services that come with the unit on a Lifetime basis. I assume you have seen on it that they have expired. Look back here tomorrow to see if @VikramK has sorted the settings for your unit on the TT server and restored the due services. When you have them back then you should contact Customer Services to sort out refunds.

    If it is a Professional model then @VikramK will probably suggest that you contact Customer Support with your Order details.

    Try the following:-

    Tap Support at the top of this page
    You then HAVE to Sign in Top Right of next Page. (you have to do this)
    When signed in, and not before, Tap Contact Us bottom right
    Help Box appears and at the bottom is a message option
    Type Contact or Chat in the box
    If Chat is available you should be offered the chance to Tap Live Chat
    If it is Out of Hours for Chat you should be offered an option to message

    If it does not work exactly as described then try another Web Browser.

    Doug
  • Ciderboy
    Ciderboy Registered Users Posts: 2
    Novice Seeker
    Thanks
    It’s a professional.
    I tried several times to contact support but the page had a fit every time, so looks like I’ll have to try another browser.