tomtom GO 520 stopped going into sleep mode

Bronky
Bronky Registered Users Posts: 4
Apprentice Seeker
edited December 2021 in Devices using Wi-Fi®
my GO520 stopped going into sleep mode after doing the latest update, how do i fix the problem?

Answers

  • Lochfrass
    Lochfrass Posts: 17,776
     Superuser
    You can try it with a reset:
    When the device is on, press and hold the On Button about 20sec till the device restarts with the drum sound. When you hear the drum Sound leave the button.

    or
    set it to factory settings. Menu/settings/system/reset device.

    I hope one of them works. ;)
  • Bronky
    Bronky Registered Users Posts: 4
    Apprentice Seeker
    Lochfrass, I have tried both of those a couple of times each with no luck, when the power is disconnected the unit just flashes the TomTom logo