Syncing Activities

cormacw
cormacw Registered Users Posts: 2
New Seeker
edited January 24 in TomTom Sports
Hello
My Spark 3 stopped Syncing Activities... I've deleted the App reconnected etc but nothing works..can anyone advise?
Thanks

Answers

  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    You should reset the phone connection following these steps. First you need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again and remove the TomTom_MySports folder from the internal storage of the watch (plug it into a computer and you will see it as a hard drive and can delete it there). The steps are: uninstall the app, remove or forget the watch from the phone's BT menu, factory reset the watch, reinstall the app, select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.
  • cormacw
    cormacw Registered Users Posts: 2
    New Seeker
    Hi Tfarabaugh

    Many thanks for the detailed explanation....unfortunately it hasn't fixed the error but I think this is due to the fact that I can't seem to perform a factory reset on the watch. I've opened the app on the phone and laptop however there is no where I can reset!

    Thanks all the same...time for a Garmin I think!
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    For computer connection issues, is there any damage to the pins in the charger or the contacts on the watch? If any of the pins are bent or deformed straighten them out with a pin and make sure the contacts on the back of the watch are free of tarnish or grime. Also make sure it is fully snapped into the cradle. Are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection)? A few things to look at (and I apologize if some are very basic, but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB port free of any debris or blockages?
    5) Is the Connect software running (is there an icon for it in the notification area)?
    6) Did you install Sports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?