Why don't I see waypoints?

gadgetGlenn Registered Users Posts: 2
New Seeker
I use the TomTom Go Navigation App on my iPhone 8 plus. I use My Route App Routeplanner to access routes planned by members of a group I am a member of but I don't have a My Route subscription.

I am able to import a ".gpx 1.1" file from My Route into TomTom My Drive via "My Routes". When I do this all the various waypoints are shown in My Drive and everything seems fine. However, when I "sync this route as a track with my devices" so that the route appears in My Routes on my navigation App, the route is shown but none of the waypoints appear.

Am I doing something wrong? Am I importing the wrong file? Does the Navigation App not support the inclusion of waypoints do you know? Any assistance you can give would be appreciated.


  • lampard
    lampard Administrators Posts: 5,944
    Hi @gadgetGlenn

    Welcome to the Community! This is a known limitation. You can sync route with waypoints from MyDrive, but waypoint won't be depicted in the app. The route will be properly synced in terms of the shape, but waypoints won't be there in the app. We will take these into consideration as improvements for upcoming releases.

    Best, lampard
  • gadgetGlenn
    gadgetGlenn Registered Users Posts: 2
    New Seeker
    Thanks lampard - at least I now know that I’m not doing anything wrong. As you say, the shape of the route and directions are all good but there are a couple of places where I’m supposed to stop en route. I have tried adding one of these waypoints to the route once the route is synced in the App but I don’t seem to have the normal “Add to current route” option when holding my finger on the map - only “Add to my places”. Is there any other way to do this please?
  • [Deleted User]
    [Deleted User] Posts: 0
    Supreme Pioneer
    @gadgetGlenn Hi :)

    How are you adding the waypoints? Manually while in the navigation? It should show the waypoints.

    Just it cant' sync POI's or routes yet, as it states in the MyDrive,

    have a wonderful day!