Update failure TomTom GO 5200

PAJF
PAJF Registered Users Posts: 4
Apprentice Traveler
edited December 2021 in Devices using Wi-Fi®
In march this year I had problems with the Prato update om my TomTom GO 5200. Even after recovering and restarting, the screen "Je gegevens en privay" (Eng: "Your data and privacy") appeared but the touchscreen didn't work. It stuck. I bought a new TomTom Go Discovery but after a couplle of weeks I reconnected the old GO 5200 and it worked fine. I could return the Go Discovery.
In august I did a map-update and the same troubles apperad again. Uptil now nothing helps.

Comments

  • jaume55
    jaume55 Registered Users Posts: 1
    New Seeker
    edited October 2021
    Hello, I have a GO5200 and in the last update, the device constantly self-resets, they ask me to put the factory values, but I do not know how to save my places and poids
  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    edited October 2021
    Hello,
    You must connect to Mydrive with the same credentials as your Go 5200

    https://mydrive.tomtom.com/es_es/#mode=viewport+viewport=46.42888,-1.35727,4.62,0,-0+ver=3
  • 2910
    2910 Registered Users Posts: 1
    New Seeker
    Goede dag
    Update via 135 lifetime maps lukt niet
  • mackeroo
    mackeroo Registered Users Posts: 4
    New Seeker
    edited October 2021
    i also had problems after an update in october...TT5200 was stuck
    managed to solve it with a factory reset.. and then connected to my drive... everything worked again
  • PAJF
    PAJF Registered Users Posts: 4
    Apprentice Traveler
    edited October 2021
    The recovery mode freezes. Everything seems to go well, but in the end a card appears instead of a card, the screen "Your data and privacy" and touchscreen no longer work.
  • mottafra
    mottafra Registered Users Posts: 3
    New Seeker
    Hello, I have a GO5200 and in the last update, the device constantly self-resets, what I have to do to return to the previous software?
  • DougLap
    DougLap Posts: 9,827
    Superuser
    edited October 2021
    Hi @mottafra

    Try going into My Drive in Settings and Stop Syncing to your account. If this works then continue Non Synced and Log in to the Account when required, only the Password will be required, Being logged out does not adversely affect the normal running of the unit.

    Doug
  • mottafra
    mottafra Registered Users Posts: 3
    New Seeker
    done, I'll let you know
  • mottafra
    mottafra Registered Users Posts: 3
    New Seeker
    thanks, it's working :)=)
  • DougLap
    DougLap Posts: 9,827
    Superuser
    Hi @mottafra

    Glad your sorted. Try logging in from time to time to see if it is sorted by an update.

    Doug
  • PAJF
    PAJF Registered Users Posts: 4
    Apprentice Traveler
    Nice that it sorted out for mottafra, but my problem still exists:
    The recovery mode freezes om my TomTom GO 5200. Recovering seems to go well, but in the end instead of a map, the screen "Your data and privacy" appears and the touchscreen no longer works.
  • boronczyk.bartosz_un38
    boronczyk.bartosz_un38 Registered Users Posts: 5
    Master Traveler
    I've just found the way of getting 5200 out of update loop. It kept updating itself starting from 70% up to 98% and back to 70. Firstly it wouldn't even start updating. Resetting the device connecting to my drive on laptop did not help at all. Tried everything. Different logins, different WiFi networks. It just got stuck on update. Satnav was fully functional when out of the range of WIFI but as soon as it tried to update / connected to pc or WiFi it got stuck.
    Now my way around the problem was another factory reset followed by setting it up in different country and then it actually allow me to delete maps cleared all incomplete downloads (think that what happened) and then it still started with unfinished download 70% but when got to 98 it reset itself and started from 0% - at this point I knew it will work again. So changing initial system language and region cleared / or helped with the update problem. Might not be suitable for this problem but hopefully will help anyone else who got his 5200 in update loop ( it was speed camera update that was failing btw)