Anybody else having issues with TomTom being bricked by updating maps?

GMcE Registered Users Posts: 3
New Seeker
My device was bricked thru the map update process. Tried help who were much less than help. Eventually sent device to the TomTom Australia HO in Sydney. Since then no response to over 50 messages to TomTom - except they send me a copy of the email I send them. Thats not helpful. Just wondering if this is a common issue with the updating and also quality (lack there of) of the support. My device was bricked back in June and its been with TomTom since then - but no answers ....


  • YamFazMan
    YamFazMan Posts: 20,833
    edited October 2021
    Welcome to the site....
    @VikramK or @lampard the Forum Moderators should pick this up Tomorrow and check out your Tomtom repair status.....

    Stay Safe... ATB YFM
  • VikramK
    VikramK Administrators Posts: 13,815
    edited October 2021
    Hi @GMcE
    I reviewed your case, and it seems that you have sent the device to the HO address without booking an RMA/Repair (Return Material Authorization).

    It's not recommended sending a device to the office without going through a standard repair process; it becomes difficult to track or ensure if the package has reached the concerned team or department.
    Due to the COVID lockdown and restrictions, I guess the device was not delivered.

    As per the latest update on your case, I see that our team has collected the device from the post office.

    I am sending a heads-up to our customer service team, they will get back to you with further details.

    Thanks, Vikram
  • GMcE
    GMcE Registered Users Posts: 3
    New Seeker
    I sent the device after weeks of TRYING to get TomTom help - none of which came. There are over 45 emails to Tomtom...... plus chats. I have been chasing TomTom for months now ... and its NOT fun nor should I have to and it was cause3d by faulty Tomtom update *(your staff admitted there was some fault in my account at your end - you can check the chat re that - and they said they fixed it - however that bricked the device).
    The update failed and ONLY allowed the NZ map despite I am in Australia and had only Aust map previously. The update also failed to install some minor patch that Tomtom issued which was about 19kB.
    I followed the instructions from your help people and that bricked the device.
    After asking and asking and getting nothing .... I sent the device to TomTom. Had Tomtom advised to send to it some other place I would have and Tomtom had multiple opportunities to do it but failed. So its great for Tomtom to say after the fact I should have sent it to some other address but you should have done that weeks before I sent it and I did tell Tomtom I was going to send it - and no one in tomtom said where to send it.....
    Recommend you read the transcripts of the chats and emails - very enlightening on how not to operate a help system.
  • GMcE
    GMcE Registered Users Posts: 3
    New Seeker
    Part of the chat transcript follows

    Type: image/png
    Size: 855918
    (12:20:58 PM) Neha C: There were some corrupted files in your account, I have removed it now.
    (12:21:05 PM) Neha C: Device will finish download now
    (12:21:19 PM) Neha C: Please restart it and connect again then start the download
    (12:21:55 PM) Neha C: You can try these steps and if there will be any issue you can reply to my email which you will get after this chat.

    You will also get the chat transcript of this chat on email, you can follow that as well.