Updated Device - Now Won't Start — TomTom Community

Updated Device - Now Won't Start

Hi All,

Decided to update my Tomtom Go 60 for the first time in 5 years. I had held off because previous experience (about 10 years ago) had taught me that Tomtom updates were terrible. however my maps were outdated and I had no option.

I downloaded the software on my PC and followed all the instruction. It all seemed to work well but after about 30 minutes it (PC software) came up with an error saying no internet access and it would automatically restart when a connection was established. My internet was up and working fine and I even disabled the firewall to ensure nothing was being blocked. I left it for 2 hours and it did not move on so I clicked close on the app. I restarted the app and it showed there was nothing connected, so I restarted the device and still no luck and now the added bonus of the TomTom not starting.

When I turn the device on the logo appears, the drum sound plays, it flashes white for less than a second, then goes black and the logo appears again (with no drums).

I have tried to get into recover mode but it does not work. Holding the power button down just causes the device to restart I get no further.

Spoke to support and they said nothing they can do I need a new one. I really cannot understand how updating your device can brick a system like this. As I said it happened 10 years ago and now again and google is littered with people having similar issues.

Answers

Sign In or Register to comment.

Who's Online in this Category0