My Go Premium won't restore when connected to MyDrive Connect — TomTom Community

My Go Premium won't restore when connected to MyDrive Connect

Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
I have a TomTom Premium X and recently it has gone into recovery mode somehow. When it starts up it just keep showing a screen with computer and my tomtom device with a cable between with an X.
I've tried connecting to my laptop by USB cable and Mydrive Connect starts and recognises my device and starts to restore but it only gets to about 10% then disconnects or restarts my device then when the device restarts it connects starts the restore for about 10% then switches off again. This will just continue this cycle if its left connected, starting and stopping.

I've searched and found various post about this and suggested remedies. I've tried uninstalling Mydrive Connect and reinstalling, checking firewall settings, checking that my USB isn't going to sleep etc but still can't sort this out.

Any help would be much appreciated before I through the thing out the window.

Answers

  • Willy875Willy875 Posts: 2,346 [Exalted Pioneer]
    Get help from Tomtom support.

    How to contact TomTom customer support by chat or email
    https://help.tomtom.com/hc/en-gb/articles/360015568919/
  • Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
    Sorry but I’ve click on the link and I still can’t see how to get help by chat or email.
  • DougLapDougLap Posts: 8,865
    Superuser
    Hi @Dave_Dixon

    Try the following:-

    Tap Support at the top of this page
    You then HAVE to Sign in Top Right of next Page. (you have to do this)
    When signed in Tap Contact Us bottom right
    Help Box appears and at the bottom is a message option
    Type Contact or Chat in the box
    If Chat is available you should be offered the chance to Tap Live Chat
    If it is Out of Hours for Chat you should be offered an option to message


    If it does not work exactly as described then try another Web Browser.

    Doug
  • YamFazManYamFazMan Posts: 20,072
    Superusers
    edited September 20
    Hi
    @Dave_Dixon
    Welcome to the site....
    It looks like something happened to crash the operating system, and that the Recovery Mode may have automatically started on your device....

    General info for Recovery Mode....
    Note... The Recovery Mode procedure will >> NOT << work with the device connected over Wi-Fi....
    For Recovery Mode to work, MyDrive Connect >> MUST << be running on your PC, and be capable of displaying as >> CONNECTED << in MyDrive Connect...
    The device MUST be connected to your PC using the supplied USB Cable with MyDrive Connect running in the background for the Recovery process to complete....

    Installing MyDrive Connect....
    Here... https://help.tomtom.com/hc/en-gb/articles/360013959499-Installing-MyDrive-Connect
    ___________________________

    See Tomtom FAQ... Navigation device not starting or displaying a cross....
    See... https://help.tomtom.com/hc/en-gb/articles/360013959579-Navigation-device-not-starting-or-displaying-a-cross
    If Recovery mode has Auto Started, it will bypass the Text screen and the 3 presses of the power button... And will already be at a stage of Recovery somewhere between the 'Spinning-disk' image shown in bullet point (5) and the bullet point (7) image showing the recovery progress count up to 100%

    Once Recovery Mode is initiated, and if a connection to MyDrive Connect has NOT established... Recovery Mode will continue to attempt to connect to MDC until the Server eventually times-out....
    Any attempts at a Restart of the device... Recovery Mode will continue to attempt to connect to MDC until the Server eventually times-out

    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    Chat… Will be available during Normal Office Hours
    Email… Will be available outside of Normal Office Hours

    Step by step tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1771083/#Comment_1771083

    ATB YFM
  • Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
    Thanks, I've managed to contact someone on the Chat now and they are escalating this. I'm just waiting for an email.
  • Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
    edited October 18
    I thought I'd just come back on here and give some update on this issue with my device.

    I'm not happy with the service I have received from TomTom support.

    I managed to contact someone via the online chat and went through various tests, changing cables etc. I tried connecting on two other peoples computers in case it was a problem with my computer, nothing resolved the issue.

    I was then told that I would need to send it back to TomTom for repair and if it's out of warranty there would be a charge, which it was by 4 months. The charge turned out to be £93! I tried to argue that as this was a software issue not a physical fault or damage I shouldn't need to pay but they insisted that I would need to pay.

    I begrudgingly paid the fee and my device was picked up by UPS on the 29th September going to Romania. It arrived at Stansted on Friday 1st October where it is now sitting in a warehouse, for 2 weeks!! I can get regular updates from UPS via the app but can't contact them to find out what the hold up is. I have been contacting TomTom regularly, via email, to try and find out what is going on but it usually takes a day or two to get an answer and then I'm not given a reason why its being held at Stansted.

    I am so thoroughly p**d off with this that this morning I've tried contacting TomTom direct to raise an official complaint. I found some numbers on the internet but both numbers are unavailable, I know it says on the support page that the telephone lines have been suspended due to COVID!!

    I'm at my wit's end with this now and just wondering if anyone has any suggestions or alternative ways of contacting TomTom to raise a complaint.

    Thanks in advance Dave
  • YamFazManYamFazMan Posts: 20,072
    Superusers
    edited October 15
    Hi
    @Dave_Dixon
    @VikramK or @lampard the Forum Moderators should pick this up on Monday and maybe check out the status of your repair.....

    Stay Safe... ATB YFM
  • Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
    Thanks @YamFazMan,

    I’ll wait and see what they can come up with.
  • VikramKVikramK Posts: 12,711 Moderator
    Hi @Dave_Dixon
    I have sent a heads-up to our customer service team. They will get back to you with any updates on the repair status.

    -Vikram
  • Dave_DixonDave_Dixon Posts: 10 [Master Traveler]
    Thank you @VikramK

    I have this morning received an email apologising for the delay and stating that as the device is still stuck in customs I am to be sent a replacement unit.

    I just hope that it too doesn't get stuck in the delivery chain.

Sign In or Register to comment.

Who's Online in this Category0