Premium X randomly reboots during Journey and address search is really slow

EAB_DW
EAB_DW Registered Users Posts: 2
Apprentice Seeker
edited December 2021 in Devices using Wi-Fi®
Why does my device reboot for no specific reason during a journey?
Why is search function so slow?
What happened to 3D buildings?
My 6000 is faster than this model!!!!

Answers

  • Dalglish_28
    Dalglish_28 Registered Users Posts: 3
    New Seeker
    mine was doing this also. - now it has stopped working entirely- one moment fine the next just a blank screen. and trying to get customer service is like trying to get an audience with the Pope
  • Terry1964
    Terry1964 Registered Users Posts: 1
    New Traveler
    Reported this problem a few month ago even uploaded video footage of the device resatarting but tomtom do not seam to feel there is a problem
  • YamFazMan
    YamFazMan Posts: 21,154
     Superuser
    edited September 2021
    Hi
    @EAB_DW
    Welcome to the site....
    EAB_DW wrote: »
    Why does my device reboot for no specific reason during a journey?
    (1)... I find the Wi-Fi devices are more stable and more responsive in general use when you 'Forget' the Wi-Fi connection....
    See... https://discussions.tomtom.com/en/discussion/comment/1763247/#Comment_1763247
    EAB_DW wrote: »
    Why is search function so slow?
    (2)... See bullet point (1)
    Also check... 400 MB is considered the bare minimum Free Working Space
    The more Free Space, the faster the device will operate... is the device stuffed full of rarely used Maps ???
    Check Free Space... Check... Tap 4Dot (.... Menu) --> Setting --> System --> About... Scroll down to Free Space....
    EAB_DW wrote: »
    What happened to 3D buildings?
    (3)... Is your driving view 2D Rotate in direction of travel (NO 3D Buildings in the 2D Rotate in direction of Travel Driving View)
    Are 3D Buildings turned off in the Settings... Check... Tap 4Dot (.... Menu) --> Setting --> Appearance --> Guidance View... Turn on Show 3D Buildings & 3D Landmarks
    EAB_DW wrote: »
    My 6000 is faster than this model!!!!
    (4)... For me there's no comparison, my GO Premium is definitely faster than my GO 5000

    Stay Safe... ATB YFM
  • YamFazMan
    YamFazMan Posts: 21,154
     Superuser
    Hi
    @Dalglish_28
    Welcome to the site
    Mine was doing this also. - now it has stopped working entirely- one moment find the next just a blank screen.
    I find the Wi-Fi devices are more stable and more responsive in general use when you 'Forget' the Wi-Fi connection....
    See... https://discussions.tomtom.com/en/discussion/comment/1763247/#Comment_1763247
    And trying to get customer service is like trying to get an audience with the Pope
    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    Chat… Will be available during Normal Office Hours
    Email… Will be available outside of Normal Office Hours

    Step by step tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1771083/#Comment_1771083

    _________________________

    Tomtom FAQ … How to Contact Tomtom Support....
    Here… https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support

    Stay Safe... ATB YFM
  • YamFazMan
    YamFazMan Posts: 21,154
     Superuser
    Hi
    Terry1964
    Welcome to the site....
    Terry1964 wrote: »
    Reported this problem a few months ago even uploaded video footage of the device restarting, but Tomtom do not seam to feel there is a problem
    I find the Wi-Fi devices are more stable and more responsive in general use when you 'Forget' the Wi-Fi connection....
    See... https://discussions.tomtom.com/en/discussion/comment/1763247/#Comment_1763247

    Stay Safe... ATB YFM
  • malcs3
    malcs3 Registered Users Posts: 14
    Legendary Explorer
    I had a problem that my Go Premium continually freezes then restarts over and over. I found that if i turn the My Drive syncing OFF on the device then it sorts out the problem. But it means I cannot connect to the My Drive app on my phone!!