Cannot sync device

Adam77 Registered Users Posts: 1
New Seeker
edited January 24 in TomTom Sports
I have a runner 3 which won’t sync. It’s gets to 31% and gives the standard “unable to sync device blah blah” line.

I’ve done all the Bluetooth shizzle which didn’t work. I’ve deleted and reloaded which didn’t work and finally reset the watch to factory settings (thus losing years of data plus my latest runs) which also hasn’t worked. Still the same old 31% fail!!

Before I put the watch in the microwave and buy something that’s more reliable , does anybody have any ideas about why this is happening please??



  • tfarabaugh
    tfarabaugh Posts: 16,943
    You did not lose years worth of data, all activities are uploaded to MySports whenever you sync. all that is on the watch is summary data of the last 10 activities. Are you able to sync by computer (it would seem so if you could factory reset), so it is an app issue. You need to fully reset the phone connection following these steps in order. First you need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again and remove the TomTom_MySports folder from the internal storage of the watch (plug it into a computer and you will see it as a hard drive and can delete it there). The steps are: uninstall the app, remove or forget the watch from the phone's BT menu, factory reset the watch, reinstall the app, select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.

    Also look if there is any software on the phone preventing the app from getting internet access. Check all permissions are turned on and there is no security software blocking it. If none of that works it may be time for a new watch,