TomTom GO stopped working! — TomTom Community

TomTom GO stopped working!

Started my Android TOMTOM GO up last Thursday and it just shut itself down immediately after saying "loading app". Inconvenient at the the least as I was just setting off on a 5 day trip on routes I didn't know! It had worked fine the previous Sunday but I have a feeling it updated itself during the week when I transferred the new routes from mydrive.
Managed day 1 OK (I could remember that bit) but app would not start, removed and reinstalled, same. Reset phone to factory and reinstalled frm Google Play (ver 3.2.12). Now gets to saying it's about to load maps and shuts down again.
Phone is a simless Blackview BV5500 running Android 8.1 and GO has run on it for the last 15 months fine (although the navigation has had a few hiccups sending me 2 miles up a road just to take a 180 at a roundabout and go back the way I came to the junction I left the main road at!). I use the phone because it's waterproof and that's necessary on a motorbike. £60 for the phone rather than multi hundreds for a dedicated waterproof device seemed a good deal to me! The phone runs no other applications as it's just used for SatNav.
Any ideas? The chatbot support says remove the app and wait for an hour before reinstalling which I'm doing but I don't expect anything different because I already did that before.

Comments

  • lampardlampard Posts: 5,691 Moderator
    edited September 15
    Hi @XLSRider

    Welcome to the Community! By any chance, did you install the app on an external SD card? I know you already tried reinstalling the app several times, can you do the same again with the below steps and let me know if it helps?
    - Delete the following folders from the internal memory
    Android/data/com.tomtom.gplay.navapp
    Android/obb/com.tomtom.gplay.navapp

    - Delete the same folders from the SD-card (if there's any)
    - Go to Phone settings > Apps > GO and tap on Force Stop and then on Clear data
    - Restart the phone
    - Start the app again and download the map

    Best, lampard
  • XLSRiderXLSRider Posts: 4 [Apprentice Traveler]
    It was originally installed with the sd card formatted as internal storage so I suspected that the SD card had failed so I reformatted it as external storage (it would seem to be OK though as the reformat worked and the file explorer can read it)
    The error is a java Invalid enum
    class: com.tomtom.navkit.map.TomTomNavKitMapJNI
    method:.SurfaceAdapter_onDrawFrame

    Anyway I tried clearing as you suggested although the android\obb directory does not exist and it's still doing exactly the same.
  • XLSRiderXLSRider Posts: 4 [Apprentice Traveler]
    I also had to install a competitor product to be able to have satnav and this installed and ran OK. It's now been removed again though but it proves the phone storage is OK.
  • lampardlampard Posts: 5,691 Moderator
    Hi @XLSRider

    The SD card can be formatted in two modes (adoptable storage/portable storage). Please follow the steps here in the article. Hope it helps!

    Best, lampard
  • XLSRiderXLSRider Posts: 4 [Apprentice Traveler]
    OK, fixed it, sort of!

    Went back to the latest rel 2 apk that I could find (2.3.7) and that works fine. Bringing it forward to rel 3 breaks it so it looks like some change that was made wasn't tested properly (for disclosue I'm a professional software tester!). I just need to make sure that automatic updates are switched off.

    (got the apk from apkmirror).

    TomTom support needs to get its act together though, when a support question comes in that says the product worked fine in a certain configuration but now doesn't then saying it never worked in the original configuration is plainly wrong! (The official response to my query was that it had never worked in a SIMless phone, which I had stated it certainly did!). The difference between RECOMMENDED and REQUIRED escaped them!
  • szachowaszachowa Posts: 465
    Staff
    edited October 5
    Hi @XLSRider , good to see professional testers on the forum.

    We are working on the fix for the issue that you have found in adb logcat:
    class: com.tomtom.navkit.map.TomTomNavKitMapJNI
    method:.SurfaceAdapter_onDrawFrame
    
Sign In or Register to comment.

Who's Online in this Category0