Why does the app constantly start in background

walkerx
walkerx Registered Users Posts: 333
Supreme Navigator
As the title says the app seems to constantly running/starting in the background as get notifications to open the app, even though it's not set to auto-open and i've not physically opened it.

it is so annoying, i only want the app to run when i want it to run not when it decides

Answers

  • lluiscn
    lluiscn Registered Users Posts: 47
    Renowned Wayfarer
    The same thing happens to me.
  • Morpheme
    Morpheme Registered Users Posts: 12
    Master Explorer
    Me too. I notice that it appens when i turn on the BT
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    Hi there,

    Thank you for reporting this! I just want to confirm the app version installed on your phones whether it's beta or normal?

    The team is working on a fix to address it, I'll post back here once I know more.

    Best, lampard
  • Prazak
    Prazak Registered Users Posts: 14
    Legendary Explorer
    Beta
  • lluiscn
    lluiscn Registered Users Posts: 47
    Renowned Wayfarer
    8.160.0 (10581)
  • Prazak
    Prazak Registered Users Posts: 14
    Legendary Explorer
    After today update looks fine
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    Prazak wrote: »
    After today update looks fine
    There was a quick beta update 8.164.0 yesterday but we're still seeing issues with some phone models where the app starts in the background even when the Autostart is disabled in the app.

    Best, lampard
  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    On my new phone Amigo doesn't start automatically anymore with bluetooth.
    Also not in AA. The map doesn't load.
    I have to manually open the app and Then it works perfect in AA.
    Xiaomi poco x3 pro.
    Autostart enabled and battery savings off. All permissions granted always. Android 11
    Amigo 8.178
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    Thanks, @rabero1985 ! I'll check this with my team. Was it working before the latest update?

    Best, lampard

  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    Hi @lampard,
    On my old phone Huawei fig lx1 it has always worked perfect. On my new phone xiaomi, version 8.178 is the first I install on it. And on this one autostart doesn't work. I can try to delete and find Apk for previous version to try if you want.
  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    edited October 2021
    @lampard ,
    Tried with 8.176 and now with new 8.181 and no autostart with my phone. Still have to start manually to load the map in AA.
  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    edited October 2021
    b8tdj6bu8ex9.jpg
    @lampard ,
    Also with 8.185 unfortunately still no automatic start in Android auto.

    Thank you team for the fast updates. Hopefully they find a solution for this one.
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    Thanks, @rabero1985, I'll forward it to my team!

    Best, lampard
  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    Amigo 8.193 still have the autostart issue on my side...
    If I tap on x in the screen and open Amigo on the Android auto main screen , it says 'something went wrong' i close the message and Amigo Starts but Then i have no Instruction panel on the left with the turns. Only the ETA panel at the bottom. So only solution for now is to really take my phone and open Amigo on the phone when I have above screenshot to make it work. If I open Amigo on my phone before i'm connected with AA, it fails also.
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    Hi @rabero1985

    Can you double-check the below permissions and let us know how it goes?
    • Check App Auto Start is allowed. e.g. XiaoMi - Open Security app > Permissions > Auto-start. Enable “Autostart” for AmiGO.
    • Check the “Show on Lock Screen” Permission is enabled. Apps → Permissions → Other Permissions → AmiGO → Show on Lock screen.

    Best, lampard
  • rabero1985
    rabero1985 Registered Users Posts: 192
    Exalted Navigator
    edited October 2021
    Hi @lampard ,
    I checked this and autostart is enabled.
    9gxazumrgtfe.jpg
    Also no battery saving.
    d5ok04qtzww4.jpg

    The show on lock screen was disabled.
    So i switch it on and i have the same problem.

    zo1mmspdkm42.jpg
    b0bdc3kzux7c.jpg
    When i close amigo with X button and tap on Amigo in AA it opens but if I plan a route i get no instruction panel
    eq5j1wzw0rhk.jpg

    But thanks to you with "the show on lock screen" suggestion, i found this option panel and played around with it. Now it turns out when i ALSO enable the option:

    Display popup screen when app is running in background
    bjltla9si30u.jpg

    IT WORKS !!!!!
    So i don't know why, but if this is disabled it doesn't start up automatically in AA.
    If I switch this on (enable it) IT WORKS !sgruji7ia21t.jpg

    Thank you for the suggestion !
  • lampard
    lampard Administrators Posts: 5,954
    Moderator
    This is interesting, thank you for sharing this @rabero1985 !

    Best, lampard