TomTom Services not working

Mochi
Mochi Registered Users Posts: 2
New Seeker
The live traffic services of the TomTom Go app on my android is suddenly not working anymore. I get no more realtime updates. Anyone know what's causing this? I have an active subscription and also sharing my location , have proper internet connection etc. It worked fine before....
Tagged:

Comments

  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    edited September 2021
    Hi @Mochi
    Welcome to the community!
    Could you try few steps as below-

    1. Quit the app
    2. Restart the phone
    3. Open the app and check if it will connect

    Thanks,
    Vikram
  • Mochi
    Mochi Registered Users Posts: 2
    New Seeker
    Hello @VikramK,

    Restarting does not help.

    Mochi

  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    I have the same issue. Online services stopped working for me on Friday 03/09/2021. It's not fault of the phone, subscription is valid, I can still log on to my account with my saved data. Traffic doesn't work on two phones. I use app version 1.17.7 because I don't like new ones.

    Now I have to use Here Maps, because of lack of traffic updates on TomTomGo app which worked well for 4 years.
  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    @Mochi @Couiza
    Could you mention the name of the service provider and the network you are using?

    Thanks.
  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    I don't think it's relevant, since it doesn't work on wifi at home either. So I doubt my mobile network just blocked it (Threee UK).
  • RedSpecial62
    RedSpecial62 Registered Users Posts: 22
    Outstanding Explorer
    Working for me in the UK (android - O2)
  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Couiza wrote: »
    I don't think it's relevant, since it doesn't work on wifi at home either. So I doubt my mobile network just blocked it

    Thanks Couiza
    I will forward that...
    The team is looking at different reasons that could be impacting the traffic connectivity..
    Is the SIM using the 3G or the 4G network?



    - Vikram.
  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    As I said, it doesn't even work on wifi at home. That phone connects to hotspot from another phone via WiFi, it doesn't connect directly to internet. And it's the same on two phones, Motorola G5 on Android 8 and Xiaomi on Android 11. It stopped working on both on the same day. Looks like service was cut off to old version of app.
  • mvanheesch
    mvanheesch Registered Users Posts: 22
    Outstanding Explorer
    Hi,

    I have the same kind of issue already quite some time (see another topic I opened a while ago "Online when Internet through wifi is interupted").
    No progress so far, takes ages for TomTom to investigate/fix or come back with some information unfortunately.
  • explor202
    explor202 Registered Users Posts: 17
    Master Explorer
    Same issue here on 2 different Samsung devices (Tab A, wi-fi only and A52 on US Mobile). @VikramK have the live traffic services been disabled for the older versions? (I still like 1.18 the best)
  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    edited September 2021
    That's my thinking too, old version of apps blocked from Live Traffic. I use 1.17.7, because I don't like new one.

    There's review in Google Play from 11/09/2011 and reviewer says that traffic stopped working for him in 1.17 version.
  • explor202
    explor202 Registered Users Posts: 17
    Master Explorer
    I can confirm live traffic is back, at least on my A52.
  • JurgenJ
    JurgenJ Registered Users Posts: 2
    New Seeker
    Have the same issue with TomTom Go Android 1.8.1 on my Nokia Android 11 phone.
    No HD traffic either via WIFI or 4G
  • explor202
    explor202 Registered Users Posts: 17
    Master Explorer
    I also checked an older Tab E that's wi-fi only, it too had live traffic. I'll check my head unit and Tab A later, but I'm expecting it to work on those too.

    Tab A and A52 run 11, head unit is 9 and Tab E is stuck with 4.4.
  • explor202
    explor202 Registered Users Posts: 17
    Master Explorer
    Live traffic works on all of my devices.
  • JurgenJ
    JurgenJ Registered Users Posts: 2
    New Seeker
    Problem seems to be resolved
    As of this morning, live HD traffic services functionality has been restored.

    Guess it was a hick-up @ TomToms end as so many users experienced that same thing (read similar comments on other communities too)
  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    Great, will check my other phone and if it works ok, restore old version on another device.
  • Couiza
    Couiza Registered Users Posts: 6
    Master Traveler
    I can confirm, it works ok now.