Device not connecting since upgrade

harleyg98
harleyg98 Registered Users Posts: 13
Master Traveler
My TomTom Rider 450 had been connecting to my Mac without issue for several years.
I received notification of the map update today - 27th August 2021.
Having booted the MyDrive application I was advised it needed updating - which I allowed it to do.
Now, when I connect the device via the USB it isn't recognised.
The USB cable must be ok as the device recognises it is connected and charges from it - but the device doesn't default to the usual 'connecting to computer, etc'
I can only conclude there is an issue with the updated MyDrive Connect App.
I am running macOS High Sierra 10.13.6 on a 27" iMac.
I checked in the Network settings and the device is recognised - but is listed as "Not Connected"
Clicking "Advanced" and renewing the DHCP Lease has no effect - the device remains 'red'
Please advise

Comments

  • rider1rider
    rider1rider Registered Users Posts: 1,424
    Exalted Pioneer
    write to customer care email
  • harleyg98
    harleyg98 Registered Users Posts: 13
    Master Traveler
    Have emailed TomTom support - so far no response.
    I'm not holding my breath - past issues indicate they're ok working with PC (DOS) connections but a bit wanting when it comes to Apple Mac's.
  • lampard
    lampard Administrators Posts: 5,966
    Moderator
    Hi @harleyg98

    We can try re-installing the drivers for your device. Can you try these steps below and let me know if this works for you? (Steps are bit old to be honest )
    • Click on the Apple menu>choose System Preferences> Choose Network
    • Select the network service for TomTom navigation device in the left hand pane. (The dot next to the service for your navigation device will turn red and then back to green.)
    • Delete the network selection service for TomTom clicking the minus (-) symbol at the bottom left and then click Apply. Click the plus (+) button at the bottom left and select the TomTom Interface. Start MyDrive Connect again: it will show the device as being connected (orange dot and Self-assigned IP address)
    In some cases, the pop-up will not appear. In this case:
    • System preferences > Network> Click Apply>Click the "+" (bottom left)
    • Under Interfaces choose TomTom and click Create>Click Apply
    If no IP address is assigned and the dot stays red, set the address manually:
    • Click on TomTom on the left>Select Manually in Configure IPv4 and enter:
      IP Address: 169.254.255.2
      Subnet mask: 255.255.255.252
    • Click Apply.

    If this fails, try using a different computer to see if it’s only happening with this machine.

    Best, lampard

  • harleyg98
    harleyg98 Registered Users Posts: 13
    Master Traveler
    Thanks, but your solution doesn’t work.
    I’ve deleted TomTom from the Network box
    Then booted MyDriveConnect
    This window shows the Rider 450 as being “! Not connected”
    I’ve then connected the TomTom 450 - but MyDrive Connect still shows as “! Not connected”
    Selecting + in the Apple Network box gives the following options:
    Select the interface and enter a name for the new service.
    Thunderbolt Bridge
    Bluetooth PAN
    Wi-Fi
    FireWiire
    Ethernet

    VPN
    PPPoE
    6to4

    As the device is not being seen (presumably as a USB connection) there is no reference to it in the Apple Network box

    Next to the + – There is an option to “Import Configurations” - but I have no source.

    I have tried this on my MacBook Air with the same result.

    I assume the TomTom connection (in the Network box) is created when a connection is detected.

    The TomTom 450 switches on when I connect it via the USB cable - which surely indicates the cable is ok - however my computer(s) don’t recognise the TomTom 450 - either as a viable Storage Device etc.
  • harleyg98
    harleyg98 Registered Users Posts: 13
    Master Traveler
    As the USB cable is charging the unit I'm confident it's working ok. However, just to be sure I've ordered a replacement - which should be with me tomorrow.
  • harleyg98
    harleyg98 Registered Users Posts: 13
    Master Traveler
    Thank you for the response.

    I ordered a new USB cable - Aieve – specifically designed for TomTom Sat Nav - and my unit is now connects.

    I’m mystified why the existing cable failed to work - as it’s the original cable - but can only conclude it must have become faulty/damaged.

    I have now been able to update my device.

    It’s obviously one to add to your database of potential connection issues.

    Thanks again for your response.

    HarleyG98