TomTom Go 40 is stuck updating

Go40user
Go40user Registered Users Posts: 3
Novice Seeker
hello everyone,

our TomTom GO 40 worked perfectly, but I thought it needed an update.
MyDriveConnect downloaded, Go40 linked, account created, everything went well.
Update took a long time but seemed to go well. Until the whole update crashed...

And now..., GO 40 only starts up with drum sound and logo TomTom and nothing else.

Contacted TomTom, received an email with an explanation to boot GO 40 in recovery mode (bios) but this does not work. When holding the on/off button, GO 40 always reboots with drum sound, but never in recovery mode. It is also no longer recognized by MyDriveConnect.

TomTom is now coming up with an offer for a replacement, but that is not an answer to my question.
Surely there must be some way to get the data back on the device?

I've already reinstalled MDC twice, had the Go 40 on the charger for 4 hours, tried different USB cables, nothing helps.

In the meantime I have already found out that the update (Europe) was too large for the internal memory. Switching to Benelux due to lack of space is no problem for me. I would also like to perform this with MDC, but then we must first have a connection again! Device is used without additional memory card.

Who knows what advice?
Thank you in advance, a satisfied TomTom user for almost 20 years (and hopefully it will stay that way...)





Mod edit: Machine translated (Dutch)

Answers

  • VikramK
    VikramK Administrators Posts: 14,712
    Moderator
    edited August 2021
    Hi @Go40user
    Welcome to the community!
    Do you have a memory/SD card inserted?
    If yes, can you try removing it and then try the update..

    - Vikram
  • Go40user
    Go40user Registered Users Posts: 3
    Novice Seeker
    edited August 2021
    the device is used without additional memory card
  • Go40user
    Go40user Registered Users Posts: 3
    Novice Seeker
    edited August 2021
    after update:

    * starts tomtom with drum sound and then hangs, tomtom logo remains visible
    * can't boot tomtom in recovery mode (bios)
    * TomTom is no longer recognized by MyDriveConnect
    * reinstalling MDC doesn't help
    * uninstalling drivers doesn't help

    I am afraid that some important data on the tomtom device is damaged due to the fact that the update version europe is 8.2mb in size while the internal memory is only 8mb in size.

    I don't think it was technically difficult for tomtom to give a warning about this before starting the update.

    who knows what to do? thank you in advance
  • nabu
    nabu Posts: 16,890
     Superuser
    open my drive connect to CONTENT and take a screenshot
    you must have a corrupted card, or no card at all

    you will need a mini card to put in the internal memory
    and a mini sd to put the map of Europe which exceeds the content of your device
    mini 16/32 go maxi
  • DaríodelaPuente
    DaríodelaPuente Registered Users Posts: 1
    New Seeker
    I have the same problem with my GO 40. It doesn't start.
    Attached device details.
    I hope some useful support from TomTom.
  • DougLap
    DougLap Posts: 10,168
    Superuser
    Hi @DaríodelaPuente

    I see you do not have an extra memory card installed. I would suggest that you add a 16GB or Max 32GB card as I assume the map update is too big for the internal memory.

    Doug