When I connect my watch to my iMac, it no longer uploads the data to the iMac. Anyone know why?

Michale_Hobbs_2805
Michale_Hobbs_2805 Registered Users Posts: 1
New Seeker
edited January 24 in TomTom Sports
I have always connected the watch to its charging lead and that automatically opens the TomTom Sports Connect App on my iMac and uploads the activity. It still opens the App but it does not display the latest activity and has not uploaded it.

Answers

  • tfarabaugh
    tfarabaugh Posts: 16,943
     Superuser
    For computer connection issues, is there any damage to the pins in the charger or the contacts on the watch? If any of the pins are bent or deformed straighten them out with a pin and make sure the contacts on the back of the watch are free of tarnish or grime. Also make sure it is fully snapped into the cradle. Are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection)? A few things to look at (and I apologize if some are very basic, but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB port free of any debris or blockages?
    5) Is the Connect software running (is there an icon for it in the notification area)?
    6) Did you install Sports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    Has your computer had any updates recently which are blocking the app's access to the TT servers?