Can not answer phone call on the tomtom rider 500

Charles1959 Registered Users Posts: 1
New Seeker
edited July 2021 in RIDER

Last week I bought my Driver500.

I have the following config. Rider500, Samsung Galaxy fold2, and headset Cardo G4.

Problem is , I get the incoming call on the screen of my Rider but as soon as I click on it the call disapears but phone keeps ringing. I have seen that a lot of others have the same problem but haven't seen a working solution to this problem.
What can I do?

regards Charles


  • fergussion
    fergussion Registered Users Posts: 288
    Supreme Pioneer
    Did you factory reset?
  • Cribbe
    Cribbe Registered Users Posts: 1
    New Traveler
    I have the same problem. Brand new rider 550 with packtalk bold and galaxy note 20.
    If I press the green answer button on the GPS to answer it dissappear and it keeps ringing.
    I have tried to reset all Bluetooth devices but nothing works.
    I also have problem when using the call button on the GPS, I'll get the notification to speek after the tone but that doesn't work either.
    Any one else having these issues or have an solution?
  • raesewell
    raesewell Registered Users Posts: 180
    Exalted Navigator
    Try setting the phone to auto answer.
  • Niel_Knight
    Niel_Knight Registered Users Posts: 11
    Master Explorer
    This is a problem with the Rider 500 when a headset is bluetooth connected! Damned frustrating I know. The manual actually says if a headset is connected, you have to use the headset to answer/reject a call. Crazy!
  • Trigg64
    Trigg64 Registered Users Posts: 1
    New Traveler
    Hi All,

    I am having lots of issues with my headset and my 550, my headset is a Sena 10u Arai.
    When I connect to another rider I lose the satnav commands, also I can not make or receive calls.
    I have had email support from Tom Tom, I have done the recovery mode and factory reset. still not playing.

    I have tried connecting the headset in GPS, 2nd Phone connection modes and again same issues.

    Anyone else had similar issues and found a fix, other than throwing the 550 in the bin.

    Thanks in advance


  • Trigg64
    Trigg64 Registered Users Posts: 1
    New Traveler
    550 pile of sh*t , why have the function if it doesn't work, and putting your phone to auto answer it not an answer its a cop out , well done Tom Tom .