GO SUPREME only came with US, Mexico and Canada, cannot add uk and roi

MarkFisher
MarkFisher Registered Users Posts: 5
New Seeker
I purchased the GO SUPREME because it had worldwide maps. It only came with US, Mexico and Canada. It looks like it wants me to pay for the UK and Ireland. How do I download to device for no charge

Answers

  • nabu
    nabu Posts: 16,890
     Superuser
  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Hi @MarkFisher
    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and then try adding a new map(device should be connected to the internet)



    Regards, Vikram
  • DougLap
    DougLap Posts: 9,871
    Superuser
    Hi @MarkFisher

    If you do the following do you get lists of maps that you can freely download.

    Tap Menu
    Tap Settings
    Tap Maps
    Tap Add a Map

    If you do then Uk and Ireland will be listed in the Europe Group or you can , if you add a 16gb or max 32gb Micro SD Class 10 card, download the whole of Europe or Western Europe which will include UK and Ireland.

    Doug
  • MarkFisher
    MarkFisher Registered Users Posts: 5
    New Seeker
    all that I get is North America
  • MarkFisher
    MarkFisher Registered Users Posts: 5
    New Seeker
    I did the soft reset and all I still get are North American Maps. Nothing for the rest of the world
  • MarkFisher
    MarkFisher Registered Users Posts: 5
    New Seeker
    somebody at TomTom please help me or provide me instructions on how to return for a refund. I purchased the GO SUpreme for world maps and all there is is North America. Soft reset doesn't work either
  • DougLap
    DougLap Posts: 9,871
    Superuser
    Hi @MarkFisher

    @VikramK or @lampard should pick this up on Monday and sort out the settings for your unit on the TT servers which would appear to be the problem. Look back then to see what they say.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Hi @MarkFisher
    For some strange reason, the services did not auto-activate.
    My team has manually added the services to your account. Please follow up with another soft reset and check for updates.

    Regards,
    Vikram