Set as default navigation for Android Auto — TomTom Community

Set as default navigation for Android Auto

HuyndaiEVHuyndaiEV Posts: 4 [Master Traveler]
Now that is it said to support Android Auto how can I set it as default so when I tap the 'navigation' icon it opens TomTom instead of Google maps?

I tried all tutorials on the net but cannot get TomTom to be the default navigation app.

Android auto says "customize launcher" and I can make ToTom available, but how do I access the launcher?

Phone is Samsung Galaxy A8

Comments

  • MUPMUP Posts: 250 [Supreme Pioneer]
    There is always a predefined Android Assistant rule called "Go to work"
    I use that ruleset and it works with Pixel 4 XL in a derived way:

    - if connected to my car by BT (I connect manually)
    - then start Android Auto
    - use preferred App TomTom Go Navigation

    You can also use a 3rd party App for less money to create more complecity:
    - Automate
    - Tasker
    ...
    and many more.
  • szachowaszachowa Posts: 329
    Staff
    HuyndaiEV wrote: »
    Now that is it said to support Android Auto how can I set it as default so when I tap the 'navigation' icon it opens TomTom instead of Google maps?

    I tried all tutorials on the net but cannot get TomTom to be the default navigation app.

    Android auto says "customize launcher" and I can make ToTom available, but how do I access the launcher?

    Phone is Samsung Galaxy A8

    I think we have already discussed this on this forum.
    I believe it is some limitation from Google.

    For instance I have found following on reddit: https://www.reddit.com/r/AndroidAuto/comments/i3oaek/waze_keeps_being_replaced_by_google_maps/
  • szachowaszachowa Posts: 329
    Staff
    You could also try to completely disable Google Maps in Application manager on your phone and see if this helps or not (but I think it's very hacky solution).
  • HuyndaiEVHuyndaiEV Posts: 4 [Master Traveler]
    Thanks all. figured it out (kinda): when actually using AA in the car it has a different screen :# and I can manually start TomTom.

    Ii works nicely but...
    1. Voice prompts still came from my phone
    2. The route bar / traffic bar was not shown like on the phone
    3. No charging stations (Have an EV) were shown like on the phone
  • szachowaszachowa Posts: 329
    Staff
    HuyndaiEV wrote: »
    Thanks all. figured it out (kinda): when actually using AA in the car it has a different screen :# and I can manually start TomTom.

    Ii works nicely but...
    1. Voice prompts still came from my phone
    2. The route bar / traffic bar was not shown like on the phone
    3. No charging stations (Have an EV) were shown like on the phone

    Voice prompts still came from my phone
    This is interesting, voice prompts should come from the head unit. Maybe other forum users will be able to help with this. Please check which output channel is selected in the TT GO Nav app (settings -> sounds)

    The route bar / traffic bar was not shown like on the phone
    Yup, we are aware, and we are investigating possible solutions. There is limitation coming from Google that blocks us here...

    No charging stations (Have an EV) were shown like on the phone
    Have you updated to 3.1.48? Please check: Menu -> Settings -> Other -> Vehicle profile. There should be an option there to change to EV.
  • HuyndaiEVHuyndaiEV Posts: 4 [Master Traveler]
    szachowa wrote: »
    HuyndaiEV wrote: »
    Thanks all. figured it out (kinda): when actually using AA in the car it has a different screen :# and I can manually start TomTom.

    Ii works nicely but...
    1. Voice prompts still came from my phone
    2. The route bar / traffic bar was not shown like on the phone
    3. No charging stations (Have an EV) were shown like on the phone

    Voice prompts still came from my phone
    This is interesting, voice prompts should come from the head unit. Maybe other forum users will be able to help with this. Please check which output channel is selected in the TT GO Nav app (settings -> sounds)

    On my phone only 'Ring channel" seems to work, after trying different options 'Music channel" outputs audio through the car. This seems to go over Bluetooth.

    The route bar / traffic bar was not shown like on the phone
    Yup, we are aware, and we are investigating possible solutions. There is limitation coming from Google that blocks us here...

    I'll be waiting patiently... I did see 'green' faster routes on the map though. The bar and te ability to see traffic jams beforehand is a great feature.

    No charging stations (Have an EV) were shown like on the phone
    Have you updated to 3.1.48? Please check: Menu -> Settings -> Other -> Vehicle profile. There should be an option there to change to EV.

    Yes, engine is set to 'Electric'. Today I could search and choose "Charging stations' which gave results on the map, so that is OK. What I meant was that on the phone stations are shown on the map and route bar without searching, but this probably has to to with the route bar issue also.

    TomTom is a great product, the only one I don't take wrong turns with all the time :3 and the live traffic has saved me lot's of time, many times commuting round Amsterdam pre-Covid. Also the fact that most roadworks are in the system is great. So I'm patiently waiting for it to get even better.

    I did get promted once to select car plug types but cannot get that screen again.

    I would also like to be able to be shown only fast chargers, for exampje when I choose CCS as plug type..

    I also noticed that fast chargers 'along route' were shown that are on the other side of the highway. Not too practical :)


    These last pieces of feedback I also gave on my revisited app-review.

    Regards,

    Erik
  • szachowaszachowa Posts: 329
    Staff
    Hi @HuyndaiEV,

    I will check following with the team. Thanks for the feedback!
    I did get promted once to select car plug types but cannot get that screen again.

    I would also like to be able to be shown only fast chargers, for exampje when I choose CCS as plug type..

    I also noticed that fast chargers 'along route' were shown that are on the other side of the highway. Not too practical
  • szachowaszachowa Posts: 329
    Staff
    Hi @HuyndaiEV , about following:
    I did get promted once to select car plug types but cannot get that screen again.

    This was a bug on our side, it has been fixed, so it is expected not to see it now
    I also noticed that fast chargers 'along route' were shown that are on the other side of the highway. Not too practical
    Would it be possible to share with us example route where this issue is observed?
Sign In or Register to comment.

Who's Online in this Category0