Subscription issue after update — TomTom Community

Subscription issue after update

Hi, I updated the tomtom go app yesterday (play store). But since my subscription (from the play store) is not recognized. I do see the subscription in the play store.
I already tried:
- It asked to "Herstel aankopen". I use the account that has my locations (different email than the play store) that I also use with the MyDrive app. As I purchased the subscription with the play store it does not contain a subscription.
- Clear cache from the play store (I did not remove all the data)
- Clear cache from the tomtom go app. Remove the data from the tomtom go app. Remove the app and reinstall.
exbis9pccq97.jpeg
3f5fh6of5qqp.jpeg
p79plka63yw7.jpeg

Best Answer

  • lampardlampard Posts: 5,369 Moderator
    edited June 25 Accepted Answer
    Hi @Alexvdh

    Can you try the steps from Jurgen here and let us know how it goes? (Skip the initial step and try without uninstalling the app first)

    Best, lampard

Answers

  • MUPMUP Posts: 245 [Exalted Navigator]
    Update means: Migration from old TT Go Mobile (1.18.1) to new TT Go Navigation (3.1.0) ?

    The bad news: Different eMail-Accounts could lead to the problem since Google is the top dog now.

    The good news: The TT-Support ( @lampard ) would fix it at TT's front end database.
  • lampardlampard Posts: 5,369 Moderator
    edited June 25 Accepted Answer
    Hi @Alexvdh

    Can you try the steps from Jurgen here and let us know how it goes? (Skip the initial step and try without uninstalling the app first)

    Best, lampard
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    @lampard
    Success with the post from Lampard. I removed the current version. Used incognito chrome screen to go to the play store. After login, I installed it from the web version from the play store. Now the subscription was recognized.
    It's a little strange that it was needed, but it's the result that counts.
    Thanks for your help.

    @MUP The update was just a regular play store update from the new TT Go App.
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    That did not help long. The next day there was a new update in the playstore. Updating is done automatically. Now I have the same problem again. It does not recognize my subscription. The same problem as my previous post. So the solution works, but only until a new update. That is not really what I'm looking for.
    I find out just before I want to use Tomtom.
    I hope there is a different solution...
  • szachowaszachowa Posts: 320
    Staff
    Alexvdh wrote: »
    That did not help long. The next day there was a new update in the playstore. Updating is done automatically. Now I have the same problem again. It does not recognize my subscription. The same problem as my previous post. So the solution works, but only until a new update. That is not really what I'm looking for.
    I find out just before I want to use Tomtom.
    I hope there is a different solution...

    Could you please provide info to which version was the app updated? I believe the app was updated from 3.1.0 to 3.1.48. This is strange, since update shouldn't remove subscriptions.
    I can also see that you have MyDrive account added with no subscriptions on your device, maybe this is causing some issues. Would it be possible to check if Google Play Subscription is recognized OK in the app if you log out from MyDrive in TT GO Nav?
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    My version is 3.1.48
    I do not know the previous one. But I downloaded it a day before like I mentioned in one of my previous posts.
    I logged out in the MyDrive EU app. And to be sure I removed the cache and data.
    I removed the cache from the Tomtom Go app (but not the data).
    I closed all the programs. No change. It still says "Abonnement is afgelopen"
    I than removed the data as well. Same result.
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    I just removed the app and installed it again from the Playstore app (so not from the play store website). Now it seems to recognize the subscription.
    This was without being logged in in the MyDrive EU app.
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    The play store showed a new update. The strange thing is that it was for version 3.1.48
    I do not understand this, as this morning I installed tomtom go from the play store as well. I did not check the version, but it must have been the latest as well.
    After updating I have the same problem back. No subscription. When I check the app: long press and click on the I, then click on "App gegevens in winkel" it shows that I have a 12-month subscription attached to the app.
    Extremely irritating. I just downloaded 5GB of maps this morning for the 3rd time in as many days.
    I have more subscriptions with other apps, and never experienced something similar. All works fine on my S20, except for tomtom go for a few days.

    I hope tomtom can solve this..
  • JasonthorogoodJasonthorogood Posts: 1 [Apprentice Seeker]
    I'm also having the same issue. I renewed my subscription on 27th March 2021 for one year. Have had no problems until I tried to use it yesterday. The app is now telling me I have no subscription for my account. I tried the Jurgen steps with no luck. It was working fine when I used it on 20th June.
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    After an endless wait on the chat, I talked with a support person. They would send the problem to the senior team.
    I hope that will help..
  • AlexvdhAlexvdh Posts: 9 [Master Explorer]
    I still did not get any answer from Tomtom support :/
Sign In or Register to comment.

Who's Online in this Category0