Endless loop of recovery mode.

jamespeare
jamespeare Registered Users Posts: 2
Apprentice Traveler
edited December 2021 in Devices using Wi-Fi®
Hi there,

My Go 5200 always shows an image of recovery mode as attached when it boots up.
Last couple of days, tried many things, but no way I've found to get through this screen.

Here's the relevant information.

When it's in the recovery mode:
> connected it to my Dell XPS 13 laptop directly not via any hub
- which is connected to internet via local ethernet,
> using an original cable provided.
> the device has no SD card in it.

1. then, MyDriveConnect recognises the device and tries to recover it.
2. after 100% of the recovery, the device is rebooted
3. but, only into the same recovery mode.
4. repeating 1 - 2 - 3 indefinitely.

Any suggestion or idea to restore the device?

Thanks and regards,
James
Tagged:

Answers

  • VikramK
    VikramK Administrators Posts: 13,810
    Moderator
    Hi @jamespeare
    Welcome to the community!
    Could you try charging the device via the mount or the power adapter for a couple of hours and then try turning it on and test.

    If that does not work, then I would suggest that you report this to our customer service team.

    Regards,
    Vikram
  • jamespeare
    jamespeare Registered Users Posts: 2
    Apprentice Traveler
    Hi @VikramK,

    Thanks for the feedback.

    Last couple of days, I've kept trying the same routine even after having the device fully charged, but all in vain.

    I'll contact customer service team to get a solution.

    Regards,
    James
  • cpmillsy
    cpmillsy Registered Users Posts: 4
    Novice Seeker
    so my Go Essential had exact same issue as above and I tried all the same solutions, including contacting customer service who told me £ 90 repair cost. Anybody got any other help as Sta Nav less than 4 years old ans cost £190 on Amazon
  • Hwalker1
    Hwalker1 Registered Users Posts: 39
    Master Explorer
    Just the same problem, only my device has only been used les than 400 miles and cost well over £300 two years ago, TomTom have my serial number but are still demanding that I send them the original invoice, which they hold anyway. Not a good way to build up customer confidence.
  • YamFazMan
    YamFazMan Posts: 20,828
     Superuser
    edited August 2021
    Hi
    @Hwalker1
    Welcome to the site.....
    It appears Recovery Mode has Automatically Started on your device
    MyDrive Connect >> MUST << be running on your PC, and be capable of displaying as >> CONNECTED << in MyDrive Connect...
    The device MUST be connected to your PC using the supplied USB Cable with MyDrive Connect running in the background for the Recovery process to complete....

    Installing MyDrive Connect....
    Here... https://help.tomtom.com/hc/en-gb/articles/360013959499-Installing-MyDrive-Connect
    ___________________________

    See Tomtom FAQ... Navigation device not starting or displaying a cross....
    See... https://help.tomtom.com/hc/en-gb/articles/360013959579-Navigation-device-not-starting-or-displaying-a-cross
    If Recovery mode has Auto Started, it will bypass the Text screen and the 3 presses of the power button... And will already be at a stage of Recovery somewhere between the 'Spinning-disk' image shown in bullet point (5) and the bullet point (7) image showing the recovery progress count up to 100%

    Once Recovery Mode is initiated, and if a connection to MyDrive Connect has NOT established... Recovery Mode will continue to attempt to connect to MDC until the Server eventually times-out....
    Any attempts at a Restart of the device... Recovery Mode will continue to attempt to connect to MDC until the Server eventually times-out
    ___________________________
    End
    ___________________________

    You may need to Contact Tomtom Support....
    Contacting Tomtom Support….
    Due to COVID-19, the phone service has been suspended
    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    Chat will be available during Normal Office Hours
    Email will be available outside of Normal Office Hours

    Step by step tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1771083/#Comment_1771083

    _________________________

    Tomtom FAQ … How to Contact Tomtom Support....
    Here… https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support
    __________________________
    End
    __________________________

    If all else fails ??? Maybe try....
    If I'm having problems with MyDrive Connect....
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program will usually bring MyDrive Connect back to life...
    See Step-by step instructions Here... https://discussions.tomtom.com/en/discussion/1134289/connection-problems-mydrive-connect-delete-the-home3-mydrive-connect-folders

    Stay Safe... ATB YFM
  • froggy8
    froggy8 Registered Users Posts: 46
    Master Explorer
    hi

    hope this helps

    i have had couple of tomtom staff asking for the proof of purchase so i carried on talking to different staff till one of them said 'ok, leave the repair bill to him' then i was sorted.

    all packed but need to find a printer to print the labels then i can post it off.
  • Morfi
    Morfi Registered Users Posts: 1
    New Seeker
    My Go essential has exactly the same problem.
    Has anyone had it resolved by the support team?
  • froggy8
    froggy8 Registered Users Posts: 46
    Master Explorer
    i got mine replaced and have arrived back to me few days ago.
  • YamFazMan
    YamFazMan Posts: 20,828
     Superuser