TomTom VIA 53 lost maps, can't get them back — TomTom Community

TomTom VIA 53 lost maps, can't get them back

cfaacfeacfaacfea Posts: 6 [Apprentice Traveler]
Initially my VIA 53 would not update out-of-the-box, and after trying pretty much everything twice, I finally managed to get it working by resetting the device and removing the maps. All in all an unpleasant experience which made me hesistant to update the maps again.

However, as the current maps still did not reflect the changes in speed limits that happened in my home country, I finally gathered the courage to perform an update again today. Unfortunately this turned out to be a excruciating exercise as well.

What lead to this:
- Started the update via WiFi, while the device was charging
- When checking again after a while, it reports it has lost its internet connection; chose to retry
- Immediately after, a menu with privacy settings turned up, so the software seemed to have been updated
- After filling in the settings, TomTom restarts again, but updating is stuck at 6%
- Cancelled the update, with the intention to start it over again

Now the device is stuck in some odd loop, where it complains about the maps missing and giving the option to add one. Selecting that option will result in a screen showing the available space on the system and a link where to buy maps. Selecting the compass in the upper-right corner will take you back to the initial error message, but no other options are available (the "Menu" button appears for a fraction of a second, but can't be selected).

What else did I try:
- Updating maps in MyDrive: still connects to the device, and provides the option to update, but shows the "downloading items" screen for 1 second and then switches to the same ridiculous message that tormented me during the first update, amongst others stating that "MyDrive Connect needs to be running"(!) and basically locks the application as it does not respond to confirming the message using the button below.
- Deleting the maps in MyDrive: just goes on and on, ending with the message that the server is busy.
- Resetting the device, which (surprisingly) also does nothing; it shows the "recover" screen on the device, but MyDrive connect won't connect / doesn't respond to it.

Sorry for ranting, but I'm stunned by the amount of issues a seemingly simple update causes each time. Is it still possible to fix this somehow? Thanks for reading in any case!

Comments

  • VikramKVikramK Posts: 11,908 Moderator
    Hi @cfaacfea
    I reviewed the update logs, and it seems there are downloads pending in the queue.
    These updates have to complete or fail to start fresh installation.
    Please see the explanation provided under Case3.1 in the article here-
    https://discussions.tomtom.com/en/discussion/1121560/tomtom-no-maps-found#latest

    Regards, Vikram

  • cfaacfeacfaacfea Posts: 6 [Apprentice Traveler]
    Well I can't say the link really helped, however your comment about the downloads pending gave me some hope, so I tried updating again via MyDrive Connect.

    The odd thing is that MyDrive would initially not connect to the device - only using the recovery mode, it worked, but the device itself would still show a screen indicating it is not connected. That's what I guess at least, since I never saw a different screen - it's the one with the connection between computer and device crossed out.

    Anyway, at that point, when trying to update it again in MyDrive, the device suddenly came to life and continued updating! This was also after I disabled my VPN connection, so potentially it might have something to do with this as well. Nevertheless MyDrive did not stop disappointing and gave an error message stating it lost internet connection, even though my internet seemed to work fine and the device continued updating as well; when it finished, everything was updated and working.
Sign In or Register to comment.

Who's Online in this Category0