When trying to update my TomTom GP940 with TomTom Home - the update screen just sticks on 'Loading'

praetorius
praetorius Registered Users Posts: 2
Apprentice Seeker
edited August 2021 in Map purchase & installation
I'm trying to download a newly purchased map. The Update was working and loading updates. I could see the map I had just purchased to download. I had to remove an old map to make room for the new map on my memory card. But when I returned to Update - it just gets stuck on 'Loading' without finally showing all the available downloads. I've tried restarting tomtom home, disconnecting and reconnecting my go940 but no help. Now I've paid for something I can get hold of.

Answers

  • rider1rider
    rider1rider Registered Users Posts: 1,410
    Exalted Pioneer
    uninstall and reinstall tomtom home
  • praetorius
    praetorius Registered Users Posts: 2
    Apprentice Seeker
    I already tried that. I reinstalled TomTom Home 2.21 but the problem is exactly the same. Trying to connect to Purchase Maps is exactly the same as Update my Go. I get the Loading bar and nothing happens.
  • Nicola9999
    Nicola9999 Registered Users Posts: 1
    New Seeker
    edited June 2021
    Give me the address of the developers I will pay them the right tribute for that. I have the same issue, and by this high paying services i expect excelences not dog shit. I think that iron on the teeth can change the perception of what working means instead of robbery.
  • WaynesterUK
    WaynesterUK Registered Users Posts: 9
    Apprentice Traveler
    Mine is doing this! Stuck on loading screen!!!

    What is wrong with you TomTom?!

    why doesn’t anything work !!!!🤬🤬🤬
  • jan_kessels1
    jan_kessels1 Registered Users Posts: 1
    New Seeker
    I had it in the past and now again. Bad service from TomTom!