Fiat 500 UConnect Nav not loading — TomTom Community

Fiat 500 UConnect Nav not loading

Stephen-C71Stephen-C71 Posts: 2 [New Seeker]
edited May 17 in Built in car navigation
in my 2015 Fiat 500L I have the Continental FIAT 312 VP2 ECE DAB NAV 5" UConnect unit running TomTom maps software. All other functions on unit work find, and NAV has worked fine until last week, but now on pressing Nav the TomTom log displays with the red dots to show progress during load, but just hangs on this feature. I've tried to find a hard reset for the unit but no joy. I've removed the unit so no power but on reinstall security code not required and unit still hangs in NAV mode. so now thinking what software/firmware updates can be done, but as I can't get into NAV menu to find current versions. I can get into engineering menu but no reset / reboot options there. Any tips to restore Nav function?

Comments

  • VikramKVikramK Posts: 11,908 Moderator
    Hi Stephen
    Welcome to the community! Is the device recognised when you connect it to the computer and open TomTom HOME?

    Regards
    Vikram
  • Stephen-C71Stephen-C71 Posts: 2 [New Seeker]
    Hi Vikram,
    the Continental FIAT 312 VP2 ECE DAB NAV is an OEM inbuilt unit so I've not managed to connect the device directly to TomTom HOME. I would normally prepare a USB in the car when updating MAPS via TomTom home, but as I can't get into the NAV menu I can't access the option. I would like to find out if there is a factory reset/reboot I can perform, of if i can do a firmware update without access to the Nav Menu
  • AagAag Posts: 1 [Apprentice Seeker]
    Exact the same problem here in the netherlands. Fiat 500X 5 inch built in dash u-connect. Everything works eccept tomtom hangs in startup screen.
Sign In or Register to comment.

Who's Online in this Category0