Cannot add new Go Basic to my account in myDrive Connect — TomTom Community

Cannot add new Go Basic to my account in myDrive Connect

Hello,
I have a new Go Basic device and I am stuck in a loop when I want to add this device to my account.
I added MyDrive account on initial setup on the device and that works fine and all is synchronised. But, when I connect the device to my PC (via USB cable), then MyDrive Connect (MDC) ask if I want to add this device to my account and I have to follow steps. Followed these steps en when I click on the continue button, it tries to do something but I am presented with the same screen and the continue button.
I already have a device in my account and that works fine to update via MyDrive Connect, so no problems there. I have re-installed MDC from the TomTom website, but still the same.
I have also checked Windows DeviceManagement, but nothing specific concerning TomTom is in there...

What to do to add this device to my account?
Tagged:

Best Answer

Answers

  • johncliffe223johncliffe223 Posts: 9 [Apprentice Traveler]
    edited May 10
    Tried adding my 6100 to my MDC account, just siots there going around in circles
  • VikramKVikramK Posts: 11,906 Moderator
    edited May 10
    Hi @johncliffe223 @hans.dz
    Could you try a workaround suggested by one of our users on the German community:

    "After reading through three different forums "Threads" with the same problem and with my "An error has occurred ..." problem, which some others also have, I was able to solve the riddle after many hours of searching around . The navigation system does not save the time and sets it back to 2009, especially during the reset processes. That is where the problem lies. It seems as if the update server does not want to accept this old date. I managed to get the navigation system onto the balcony so that it could read the current time and time zone, and my patience was rewarded. Once the time was read in and then strapped back to the USB port, the update process FINALLY starts!"
    - @satmonk

    Comment link- https://discussions.tomtom.com/de/discussion/comment/1756538/#Comment_1756538

    Machine translated(German)

    Regards, Vikram
  • johncliffe223johncliffe223 Posts: 9 [Apprentice Traveler]
    my tomtom is showing the current GPS time, so that is not the problem
  • johncliffe223johncliffe223 Posts: 9 [Apprentice Traveler]
    I have this before with tomtoms, I have a Garmin GPS and that just updates with no problems at all.
    not impressed with their customer support either, like something from a 3rd world country.
  • hans.dzhans.dz Posts: 3 [Apprentice Seeker]
    I will try this 'Time' solution. I will keep you updated...
  • hans.dzhans.dz Posts: 3 [Apprentice Seeker]
    edited May 10
    Doesn't work. I keep getting the Continue button ...
    I don't get an error message, it just keeps showing me the page what I have to do to add the device and when all is done (which it is) then press Continue.
  • VikramKVikramK Posts: 11,906 Moderator
    Accepted Answer
    @hons.dz
    @johncliffe223

    Could you send me the serial number of your device through a private message, please?

    Thanks, Vikram
  • johncliffe223johncliffe223 Posts: 9 [Apprentice Traveler]
    I found the solution by accident.

    Go into the system menu on the sat nav and choose reset to do a full reset.

    I did that and now my 6100 has connected and updated.
Sign In or Register to comment.

Who's Online in this Category0