Rider 500 Stuck in connect to computer — TomTom Community

Rider 500 Stuck in connect to computer

StarpineStarpine Posts: 3 [Apprentice Traveler]
So i have the TomTom MyDrive connect installed on my computer which i used to update my device in the past.

My rider 500 shows this black screen where it wants to connect to my computer.
I been trying for 3 days now to reset this device using the official guides and videos from TomTom, but i have not been succesfull.

I have held the power button down untill you see the black screen with the white text, then quickly released the button. Then i hit the power button 3 times (tried this at least 20 times with different timings) but i never got this spinning cogweel or circle. The device simply restarts and goes back to this connect to computer screen.

Ok so i connected it DIRECTLY to my computer using the original cable and this triggered the mydrive application to start on the computer. The app says restoring device, hits 100%, restarts the rider500 only to go back to restoring device. Its basically stuck in a restoring loop and my device cannot be used anymore.

The device has no physical damage, has never been opened, has never been used with an extra memory card etc.


Any hope in restoring this thing? Same thing happened with my rider 400 and i'm not planning on buying any more TomTom products after this. It would be nice to get it to start working again since its the second device and it wasn't cheap.

Answers

  • VikramKVikramK Posts: 12,146 Moderator
    Hi @Starpine
    Welcome to the community! The recovery mode is not initiating on the device.
    My advice would be to report this issue to our customer service team. They will review the logs and advise if this will require repair.

    Regards, Vikram
  • StarpineStarpine Posts: 3 [Apprentice Traveler]
    Hi Vikram,

    Any proper link where i can contact them directly? I only found a chatbot so far
  • VikramKVikramK Posts: 12,146 Moderator
    Hi @Starpine
    The steps on the link below should help you get in touch with our customer service.
    https://help.tomtom.com/hc/en-gb/articles/360015568919/

    Regards, Vikram
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    I have the exact same issue (see thread started today). My unit was working fine in the morning and I had completed a 96 mile journey using my 550.

    On return home I instigated the updates via WiFi and I now have a 550 that does not work.

    Starpine, did you find a solution to the issue?
  • StarpineStarpine Posts: 3 [Apprentice Traveler]
    @Mathew550 I have been using the chat to get in touch with TomTom support for 4 days and talked to 3 different people. I followed each of their pretty standard instructions just to cross those things off the "have you tried" list before asking for a repair procedure, which I never received from them.

    I requested another repair procedure from the store where I bought the rider 500 and the device is packed up and ready to go as we speak. In short; this was a horrible experience, both the devices and the customer service. If they can repair the device and allow me to use it for another year or so; good. When it dies again i`m mounting either a phone or a Garmin.
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    Sorry to hear your experience with TomTom support has not been successful, very disappointing. I have been very happy with my 550 but the unit is now useless unless there can be a fix, seems to be a TomTom induced software glitch. Mine will be over 2 years old so out of any warranty but I would expect it to last a few more years yet.

    Hopefully TomTom will be able to sort the issue out. My battery is at 98% on the white screen data…. but the year 1973?
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    Another question: I have created a separate thread but I am unable to see it? I am struggling to navigate through the forum. Normally you would just click on 'most recent' and it would filter as requested.
    Sorry to hijack this thread but can some one assist?
    Or are all posts awaiting moderation?
  • YamFazManYamFazMan Posts: 19,621
    Superusers
    edited May 24
    Hi
    @Mathew550
    Your Posts are here... https://discussions.tomtom.com/en/profile/comments/Mathew550
    e.g... Click on your profile --> Forum Header Top Right or Click on your profile in a post....
    A new window opens...
    Screen right --> Click on 'Comments'....
    Scroll down to your Posts....
    Mathew550 wrote: »
    (Snip) TomTom induced software glitch. Mine will be over 2 years old so out of any warranty, but I would expect it to last a few more years yet.
    Hopefully TomTom will be able to sort the issue out. My battery is at 98% on the white screen data…. But the year 1973?
    The Date shown on the white text screen for the RTC (Real Time Clock) Chip is the date embedded into the chip during the design and manufacture... The actual time is obtained when the device has a satellite fix.....

    ATB YFM
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    Hi YFM,

    Thank you for taking the time to respond. I am able to see the comments I have made against other posts, however I have started two threads now and I am unable to see these. Can you assist further?
  • YamFazManYamFazMan Posts: 19,621
    Superusers
    edited May 23
    Hi
    @Mathew550
    Did you click on the link in the post ???

    Your Posts are here... https://discussions.tomtom.com/en/profile/comments/Mathew550

    I can see all of your posts after clicking on the above link... Your latest post heads the list....

    Here's your other thread.... https://discussions.tomtom.com/en/discussion/comment/1758981/#Comment_1758981

    ATB YFM
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    Hi YFM,
    I have been clicking both links, please note these are 'comments' against other people's threads and not a fresh thread to which i have created two.

    I have created a third 'test' and I previewed this before posting and now i am able to see this. Why it would need to be 'previewed' before posting I do not know?

    Anyway, I will type out my message elsewhere and post this across to my test thread.

    Thanks
Sign In or Register to comment.

Who's Online in this Category0