iOS 14.5 and CarPlay Issue — TomTom Community

iOS 14.5 and CarPlay Issue

gsalatinogsalatino Posts: 7 [Apprentice Traveler]
With the latest update to iOS14.5, the map is no longer displayed on the CarPlay home screen, the frame appears white with the app icon.

Clicking on it opens the map in full screen and it works normally.
«1

Comments

  • ToolheadToolhead Posts: 1 [New Traveler]
    edited April 29
    huvdvfne2nma.jpg
    Same here, quite annoying!
  • JürgenJürgen Posts: 6,618
    Community Manager
    Thanks for this! We were able to reproduce this with iOS 14.5
    (GONAV-3048)
  • gsalatinogsalatino Posts: 7 [Apprentice Traveler]
    I hope the new release 2.6 will be available soon….
  • GummibandoGummibando Posts: 17 [Legendary Explorer]
    edited May 6
    @Jürgen

    Same issue here.

    Some additional comments:

    When trying to bring the app to front via the CarPlay dashboard, only a black screen is shown.

    I can get the navigation to work in CarPlay if I open the app and start the navigation on the phone prior to connecting to CarPlay.
    But then the navigation preview in the CarPlay dashboard only shows the starting location without the route.
    Please see following screenshot (I'm actually driving here along a route. The route is shown perfectly fine in the app, but not in the dashboard.)

    b4tuusv9darp.png

    When launching the app on the phone while connected to CarPlay, the app sometimes hangs in the loading screen indefinitely.

    Best, Oli
  • CuzerCuzer Posts: 7 [Apprentice Seeker]
    I get the hanging issue loads, often have to pull over and try a combination of on the app or via the phone before it eventually connects

    Never used to be this problematic for connecting until recently?
  • lampardlampard Posts: 5,601 Moderator
    Hi @Gummibando

    As Jurgen mentioned above, we already identified this issue where the dashboard doesn't work on iOS 14.5 with no route planned in the app. It appears to be an apple issue.

    I believe you have the iOS14.5 installed? You need to open the app on full screen, then go back to the dashboard and it will work (as a workaround).

    Best, lampard
  • GummibandoGummibando Posts: 17 [Legendary Explorer]
    @lampard

    Thanks. I assume the other issues I mentioned (no route display in the dashboard navigation quadrant etc.) all derive from the parent issue?
  • ArbassesArbasses Posts: 5 [Apprentice Traveler]
    edited May 17
    Hi @lampard , unfortunately it still doesn't work :'(
  • gsalatinogsalatino Posts: 7 [Apprentice Traveler]
    Updated app to relase 2.6

    The issues remain

    .

  • ArbassesArbasses Posts: 5 [Apprentice Traveler]
    @gsalatino I've the same issue New Iphone 12 & release 2.6 ....
  • RJDRJD Posts: 10 [Master Explorer]
    Yes still an issue with 2.6; doesn't seem to have resolved either "my" freezing issue nor the dashboard display without a route. Even the "workaround" doesn't work for me (opening full app then back to dashboard) - however if I input a route and then "end route" it will keep the map in the display in dashboard.
  • Grumlin55Grumlin55 Posts: 1 [New Seeker]
    Updated to 2.6 on my iPhone 12 MAX, and updated the software on my Kenwood 8019 as well. Ive tried deleting the iphone from the car stereo, and re installing it, still having the same problem.
  • ArbassesArbasses Posts: 5 [Apprentice Traveler]
    it seems that TomTom is not able to give any feedback ... to my understanding this problem has nothing to do with Apple new iOS version ....
  • DougLapDougLap Posts: 8,834
    Superuser
    edited June 7
    Hi @Arbasses

    Working fine on my.12mini. Have you tried deleting and reinstalling the App.

    Doug
  • ArbassesArbasses Posts: 5 [Apprentice Traveler]
    Hi @DougLap

    I didn't tried yet, but will try when I'm @home (do not have wifi right now) ....
    by the way many thanks for your feedback ;)
  • TMTMUSERTMTMUSER Posts: 3 [Neophyte Traveler]
    Hello,

    I am also having this issue since the update to iOS 14.5. I have tried reinstalling the app and trying different settings in the app however I cannot get TomTom GO Navigation to display properly in CarPlay without a workaround.

    The workaround that works for me is:

    - CarPlay turns on and at the dashboard page TomTom GO Navigation does not load correctly instead shows the logo like the screenshots above
    - To get the map to display I open TomTom GO Navigation by clicking on the logo, I then start any route and then shortly after end the route navigation
    - Returning to the CarPlay Dashboard page displays TomTom GO Navigation like normal

    However this workaround needs to be repeated every time I get in my car unless I have a route planned. I don't always want a route planned instead sometimes just want the TomTom GO Navigation map displayed for context when driving.

    This issue does not exist with Waze and honestly if this doesn't get fixed soon I will move to using Waze permanently as performing the workaround every time I get in the car is too much of an inconvenience.

    Hope this gets resolved soon and that my post makes it clear it's not a CarPlay issue it's a bug with the app.
  • ArbassesArbasses Posts: 5 [Apprentice Traveler]
    Hi @DougLap,

    I've deleted the App & reinstalled .... the issue is still there :(
  • gsalatinogsalatino Posts: 7 [Apprentice Traveler]
    1 month later the problem has still not been solved.

    I'm currently using Waze and:

    - it works very well and without home screen bug
    - i can control Waze with voice commands
    - the phone is less hot
    - more battery durability

    I find it absurd that a free application is more efficient than a version that requires an annual subscription.

    TomTom should think about this!
  • TTuser44TTuser44 Posts: 6 [Apprentice Seeker]
    Why doesn’t TomTom display in the CarPlay split screen, where it shows half the nav screen, and other half music controls?

    All it shows is an icon? It’s nice to have this screen so you can see the roads etc as you’re driving.
  • DougLapDougLap Posts: 8,834
    Superuser
    edited June 10
    Hi @TTuser44

    This issue has been raised by others and TT are aware. To get around the issue if you connect the Phone with a Route already created on the phone or if you have not opened the App on the phone go to the Full CarPlay display screen and create a route then go to the dashboard it should show then. If you only want the map display with no route again if you create the route then select End Route you should see the TT map in dashboard mode.

    Doug
  • TTuser44TTuser44 Posts: 6 [Apprentice Seeker]
    Thanks, I did read another thread all about this just after posting sorry!

    Seems a long standing issue, and for TT not to fix is a little worrying.

    Thanks for the work around, shouldn’t have to though, this CarPlay Home Screen is ideal for apps like TT.
  • DougLapDougLap Posts: 8,834
    Superuser
    Hi @Arbasses

    I have now experienced what you were saying. It works fine on mine in that I always connect the iPhone with a Route on it or if not I get the Full screen and create a route so never go to the Dashboard without a Route having been created .

    I have passed my experience on to TT along with another issue I have spotted with Dashboard not displaying the Correct map.

    Doug
  • DougLapDougLap Posts: 8,834
    Superuser
    Hi @TTuser44

    Your welcome. I have spotted today the fact you can have another Apps map appear in Dashboard when you are using the TT App and the other App does not have to be open at the time. I have sent info to TT.

    Doug
  • bobbygunbobbygun Posts: 2 [Apprentice Seeker]
    Hi Guys
    This is happening again. Not sure if it was the latest IOS or TTG update. Map no longer shows in apple CarPlay split screen!
  • GummibandoGummibando Posts: 17 [Legendary Explorer]
    @lampard @Jürgen

    Any news on this?
    Correct me if I'm wrong, but this appears to be an iOS bug.
Sign In or Register to comment.

Who's Online in this Category0