Stuck in recovery loop

Gareth_Bryant
Gareth_Bryant Registered Users Posts: 4
Apprentice Traveler
As others have posted, my device is stuck in recovery loop. Updates with my connect to 100%, restarts, then goes back to recovery again. Have left it doing this for over 5 hours. Have tried everything i can think of, but no success. It’s obviously just a software issue, but how can I resolve it?

Comments

  • DougLap
    DougLap Posts: 9,855
    Superuser
    Hi @Gareth_Bryant

    Lest see what @VikramK or @lampard have to suggest after they have reviewed the logs for your unit on the TT servers.

    Look back here tomorrow.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,801
    Moderator
    Hi @Gareth_Bryant
    Welcome to the community!
    My team has pushed a script that will repair the firmware on the device. Just connect it to the computer and open MyDrive Connect.

    The jobs will get processed automatically.

    Should this not help then my advice would be to contact our customer care team.

    Regards, Vikram.
  • Gareth_Bryant
    Gareth_Bryant Registered Users Posts: 4
    Apprentice Traveler
    Hi Vikram. No success I’m afraid, device recovers to 100% on version 4.2.11.4200, reboot with progress bar to 100%, then reboots again with progress bar to approx 25%, then back to restore screen and repeats above. Frustrating, as I used this unit every day on my travels around the UK, and it has lifelong maps and cameras. Hardware seems ok, but I’m not keen on replacing it (expensive!) just for a firmware/software issue. Only happened after I updated the software as recommended.
  • Gareth_Bryant
    Gareth_Bryant Registered Users Posts: 4
    Apprentice Traveler
    Is there any way the unit can be reset back to original settings? Like a re-install if you like? Or is that what my drive is trying and failing to do?
  • Lochfrass
    Lochfrass Posts: 17,770
    Superuser
    Sometimes a memory card inserted in the device can prevent recovery mode.
    I hope you do not have a memory card in the device.
  • Gareth_Bryant
    Gareth_Bryant Registered Users Posts: 4
    Apprentice Traveler
    Hi Lochfrass, thanks for the comment. No, no memory card inserted
  • richlynne
    richlynne Registered Users Posts: 1
    New Seeker
    Mine is doing the same.
    I reset, plug into computer following information and it just keeps going in a loop. It doesn’t actually turn off as it should.
    Has any solutions been available
  • Neverillfly
    Neverillfly Registered Users Posts: 0
    New Seeker
    Hey guys,

    after updating my TomTom GO 520 over Wifi, it restarted and it's now stuck at the boot screen. I tried to reset it by pressing the power button, waiting to hear the drum noise, but instead, the screen turns off and then goes back to the TomTom screen.

    I also tried to plug it into several computers, but it seems that none of them even recognize that there's a device plugged in.

    Any other recommendations?
  • YamFazMan
    YamFazMan Posts: 20,820
    Superuser
    Hi
    Contacting Tomtom Support….
    Due to COVID-19 the phone service has been suspended
    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    1st... A couple of Tips when Contacting Tomtom Support....
    Here... https://discussions.tomtom.com/en/discussion/comment/1714844/#Comment_1714844
    _________________________

    Tomtom FAQ … How to Contact Tomtom Support....
    Here… https://help.tomtom.com/hc/en-gb/articles/360015568919-How-to-contact-TomTom-support

    Stay Safe... ATB YFM
  • Bri8691
    Bri8691 Registered Users Posts: 4
    Apprentice Seeker
    My TomTom Trucker 6000 is stuck in the same loop., several months later! Its basically a brick. I gather they are not supported for repair either now ..
    I need a new satnav., but am reluctant to chance buying another TomTom now, as the update feature is broken in my opinion, (and experience) and hideously slow
  • DougLap
    DougLap Posts: 9,855
    Superuser
    Hi @Bri8691

    Contact Customer Support during normal working hours and they can sort out repair for you if needed.

    Tap Support top of this page
    You must then sim in on next page before Tapping Contact Us
    Help page appears and after a few seconds Get in Touch appears in it.
    Tap Get in Touch and during working hours Chat should appear.
    If it does not work exactly as described then us another browser

    Doug
  • Chesca56
    Chesca56 Registered Users Posts: 5
    Apprentice Traveler
    I have the same issue