tomtom go520 — TomTom Community

tomtom go520

smithassoc1smithassoc1 Posts: 3 [New Seeker]
Hi,I Just Logged into my TomTom Account & it Shows my Device is now TomTom Go Supreme
1-Why the Change???????
2-I update the Speed Camera (worked ok)
3-I cannot Search a Address in Melbourne,BUT BUT If I log into my Tom Tom On the Computer & Plan a Destination in Melbourne,it works ok ,BUT NOT ON MY DEVICE
4-The Tom Tom Go520 has a lifetime update of Maps & Speed Cameras,but after logginto it on my Computer,It wants me to Pay (that is not on)
I need to speak to a person about all of this in Australia


  • YamFazManYamFazMan Posts: 19,219
    Welcome to the site....
    Contacting Tomtom Support….
    Due to COVID-19 the phone service has been suspended
    The way of contacting Customer Services has changed
    For Tomtom Support Email or Chat lines...
    (Monday to Friday Normal Office Hours)
    1st... A couple of Tips when Contacting Tomtom Support....

    2nd... Tomtom FAQ … How to Contact Tomtom Support....

    Stay Safe... ATB YFM
  • smithassoc1smithassoc1 Posts: 3 [New Seeker]
    Neither option 1 or 2 works,The Problem I have is a few
    !-On opening my so called Go520 (now aparently Tom Tom Go Supreme)
    I had to open my Drive Connect before the update on Cameras was installed
    2- Now my WIFI will not Connect (regard less on what I Do)
    3-I cannot Search for a Location in Melbourne,BUT BUT I can I Smart Route Planner on Drive Connect
    4-This PATHETIC on the way I have WASTED 4 HOURS TODAY & I should be able to send a email or Speak to TomTom in Australia
    If I don't Get a Reasonable reply within 24 Hours,I will be Purchasing another Unit & It WILL NOT B
  • YamFazManYamFazMan Posts: 19,219
    edited April 28
    Just checked he 'Contact us' links (Option...1) For Chat & Email....
    Both are working OK for Australia from here in the UK
    But obviously the Chat lines are closed... The Email link is working OK....

    Stay Safe ... ATB YFM
  • DougLapDougLap Posts: 7,703
    edited April 28
    Hi @smithassoc1

    There is a bug on the TT system at the moment that TT are aware of where it is incorrectly suggesting purchasing some services. which may be the reason you are seeing this.

    Have you tried a Soft Reset on the unit.

    If that does not sort it then a Factory Reset may resolve it.

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    Before doing e factory Reset log into your account on the My Drive Webpage and check that your MyPlace etc are saved there so that after the reset they will be restored to the device when it logs into your account.

  • smithassoc1smithassoc1 Posts: 3 [New Seeker]
    Hi Doug,
    Thank you,you have restored my fate in Tom Tom
    After the Factort reset,All is workimg well,Again THANK YOU
  • DougLapDougLap Posts: 7,703
    Hi @smithassoc1

    Glad you are sorted. Liked the Fraudian slip that I restored your FATE in TT. 😂😂

Sign In or Register to comment.

Who's Online in this Category0