Tomtom Go 400 - MAPS EXPIRED?

rolivier2013br
rolivier2013br Registered Users Posts: 3
New Seeker
edited August 2021 in Map purchase & installation
I have a go 400 with lifetime maps but it says now that the maps have expired. How come?

Is there a problem and the Tomtom server does not see my device as a "lifetime maps device"?


Besides, I have a Tomtom collection of 16 different devices. Collectors items. :-)


My Go 400 serial : QMxxxxxxx45


Thanks for your help.



Mod edit: Please don't post private or personal information on a public forum. Thanks!

Best Answer

  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Answer ✓
    Hi @rolivier2013br

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram

Answers

  • DougLap
    DougLap Posts: 9,831
    Superuser
    Hi @rolivier2013br

    Last see what @VikramK has to say after checking your units settings on the TT servers.

    Doug
  • rolivier2013br
    rolivier2013br Registered Users Posts: 3
    New Seeker
    Thank you Doug ! @DougLap
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Answer ✓
    Hi @rolivier2013br

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram
  • rolivier2013br
    rolivier2013br Registered Users Posts: 3
    New Seeker
    VikramK wrote: »
    Hi @rolivier2013br

    Welcome to the community!
    My team has fixed the services for your TomTom, please do a soft reset and check for updates.



    Regards, Vikram




    Thank you very much, it worked ! I'm now able to update my maps. Many thanks to this great community and you all !

    Cheers,
    Roger.
  • GO-th-Mad
    GO-th-Mad Registered Users Posts: 2
    New Seeker
    Hello, my GO 400 doesn't update the europe map, last card 18 months old; new map is downloaded and begins to install but finally the device says: update failed (fehlgeschlagen)
    Soft reset doesn't help; MyDrive Connect says: device actually doesn't react.
    I surely tried a dozen times - no chance!