how do I fix my Rider 550 after it gets stuck on the logo screen — TomTom Community

how do I fix my Rider 550 after it gets stuck on the logo screen

QcorpQcorp Posts: 2 [Apprentice Seeker]
edited May 23 in RIDER
After doing an update through my drive connect my rider 550 powers on but will not move past the logo screen.
I have tried the suggestions on the videos but nothing works. How do I fix it?

Answers

  • YamFazManYamFazMan Posts: 20,067
    Superusers
    Hi
    @Qcorp
    Welcome to the site....
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

    Stay Safe... ATB YFM
  • QcorpQcorp Posts: 2 [Apprentice Seeker]
    I tried the reset and recovery mode using the original cable that came with the device. The Rider 550 acts like it is going to power on then gets stuck just before the white bar gets to the end of the power up cycle and does nothing after that. I tried it on my mac, pc and laptop.
    On the laptop I uninstalled my drive connect then re-installed my drive connect. I did the recovery mode and it did recognize the unit but it is at only 5% up date and it has been over 1.5 hours.
    I am not sure if this is normal or if it will work. Does it normally take more than an hour to update?
  • Mathew550Mathew550 Posts: 34 [Outstanding Wayfarer]
    Qcorp,

    Did you resolve your issue?
Sign In or Register to comment.

Who's Online in this Category0