How do I overcome the message "unknown navcore version" — TomTom Community

How do I overcome the message "unknown navcore version"

Baz_PrazBaz_Praz Posts: 5 [Apprentice Seeker]
I have been unable to find a suggestion as to how to fix my problem.

Answers

  • lampardlampard Posts: 5,210 Moderator
    Hi there @Baz_Praz

    Welcome to the Community! I've made some changes in the background for the reinstallation of Navcore on your device. Please soft reset the device (Press down the on/off button for 30 seconds until it makes a drum sound) and check for the updates on the device via WiFi.

    If nothing happens, try connecting to PC, and update via MyDrive Connect. When your device is turned on after a reset, connect the device to the computer. On MyDrive Connect in the right bottom corner, it will say 'updating’. Keep it connected till says up-to-date and check for the updates again to download the updates.

    Regards, lampard
  • Baz_PrazBaz_Praz Posts: 5 [Apprentice Seeker]
    Hi Lampard

    Thanks for your assistance

    I went through your suggested steps but without any joy.

    After I'd completed the steps - the message at bottom right showed " Cancel Sync" for a long long time.

    Could i try uninstalling all the TomTom apps, settings etc then doing a fresh install?
  • lampardlampard Posts: 5,210 Moderator
    edited April 12
    Hi there @Baz_Praz

    When you open MyDrive Connect, does it show an error message? If there's no error, can you see the Navcore update available for you to download under updates? I still see the download pending which I created earlier.

    Please follow the steps below to remove the HOME3 folder and start the download again:
    • If your navigation device is connected to the computer, disconnect it.
    • Right-click the MyDrive Connect icon ( Image or Image ) in the Windows notification area or Apple menu bar and then select Settings.
    • Select the tab Downloads> Click Empty download folder> Click Save Settings .
    • Restart MyDrive Connect> Click the MyDrive Connect icon ( Image or Image ) in the Windows notification area or Apple menu bar and then click Quit.
    • Start MyDrive Connect.
    • Reset your navigation device (Press down the on/off button for 30 seconds until it makes a drum sound)

    Connect your navigation device to your computer and MyDrive Connect will start the download automatically and apply the changes I made.Keep it connected till the update is complete.

    You can check for the latest updates again till it says up-to-date.

    Otherwise, the last option would be to perform a recovery mode.

    Best, lampard

  • Baz_PrazBaz_Praz Posts: 5 [Apprentice Seeker]
    Hi Lampard

    Apologies for not getting back to you sooner - I had an attempted spam attack yesterday afternoon which has taken me some time to recover from.

    Fortunately - I did not suffer any financial loss and the "damage?" was easy to fix.


    Every time that I open MyDrive Connect - there is no error message but the screen always opens with this message:-

    Unknown Navcore Version
    The system software on your device is not known by the current environment. Please make sure to install the compatible version

    I did go through the instructions that you provided but they simply ended with MyDrive (on the satnav) displaying a button (bottom right) with the words "Stop Syncing" which got terminated after an hour (or more) by my spam attack.

    I've followed your instructions again this morning with the same result i.e. satnav MyDrive is showing the "Stop Syncing" button. It's been displaying like that for forty minutes so far - but I will let it run for two hours.
  • DougLapDougLap Posts: 7,703
    Superuser
    edited April 13
    Hi @Baz_Praz

    Are you able to run the Recovery process detailed in the attached link and referred to by @lampard in his post. The tricky bit is getting the 3 dots timing right.

    This should load a fresh version of the Nav core.

    From what you are saying is it possible you have been onto a Scam Tomtom website and they have loaded the Navcore you have on the device. Also is it possible that the Spam you had yesterday is related too that.

    Doug
  • Baz_PrazBaz_Praz Posts: 5 [Apprentice Seeker]
    Hi Doug

    I don't recall having seen instructions regarding "three dots".

    I haven't yet worked out how the attack was instigated but as soon as I realised what was happening - I pulled the plug on my machine, waited, and then rebooted.

    I immediately ran ESET followed by MALWAREBYTES, neither of which detected any problems.

    After resetting a few settings - the PC was, and still is, working as before.

    This morning - I have executed the instructions that Lampard had sent me.

    The result was exactly as before, When I opened MyDrive Connect on the PC - the screen opened with the following message BUT WITHOUT ANY ERROR MESSAGE.:

    Unknown Navcore Version
    The system software on your device is not known by the current environment. Please make sure to install the compatible version.


    After I had reset the satnav and reconnected it to my PC - it came up with the words "One moment please.

    That was about an hour ago and that message is still displaying on the satnav screen.
  • YamFazManYamFazMan Posts: 19,218
    Superusers
    edited April 13
    Hi
    @Baz_Praz
    Further to Vikram's & Doug's posts....

    Tomtom FAQ... Recovery Mode.......
    Navigation device not starting or displaying a cross... (Recovery Mode)
    See... https://help.tomtom.com/hc/en-gb/articles/360013959579-Navigation-device-not-starting-or-displaying-a-cross

    Recovery mode usually rolls the NavCore back to the previous version....
    Baz_Praz wrote: »
    (Snip)
    I don't recall having seen instructions regarding "three dots"
    (Snip)
    Doug is referring to the 3 Clicks of the power button...
    The three clicks of the Power button are 1,2,3 as quick as that....
    Probably all 3 in around a second.... There is a knack to getting it right....

    Stay Safe... ATB YFM
  • Baz_PrazBaz_Praz Posts: 5 [Apprentice Seeker]
    Hi YamFazMan

    Thanks for your input - it's the first comment that has clarified the required speed of button presses.

    I've tried 3 times this morning (without success) - but I'll carry on later.

    I've lost count of the number of times that I've actually tried - but I'm not going to give up!!!
Sign In or Register to comment.

Who's Online in this Category0