Bluetooth stopped connecting — TomTom Community

Bluetooth stopped connecting

ozpom04ozpom04 Posts: 5 [Apprentice Traveler]
My Go620 stopped updating traffic - bluetooth showed connecting then disconnected -connecting then disconnected-connecting then disconnected.
Hands free & messaging shows as connected but data for traffic & other services now shows =unable to connect.
I deleted and re added my phone and my wifes but same happens so it isnt the phone bluetooth
I have connected via hotspot but bluetooth has been OK and is a better option so, has the device developed a fault or is there an issue with TomToms services??

Comments

  • DougLapDougLap Posts: 7,731
    Superuser
    Hi @ozpom04

    What phone?

    Doug
  • ozpom04ozpom04 Posts: 5 [Apprentice Traveler]
    iPhone se IOS 14.4.2
    Has been connecting ok but not sure when it stopped
  • DougLapDougLap Posts: 7,731
    Superuser
    Hi @ozpom04

    An issue with Bluetooth connections started when they issued IOS13 as at that point the pairing of an iPhone with your unit and involving the My Drive App stopped working.

    I pair my units as follows.

    Firstly delete all current pairings and turn the Phone and TT unit Off /On after .
    Now go to Personal Hotspot in the iPhones Settings and turn the Option On.
    Do not open My Drive App at any point in this process as it will not work.
    Go to Bluetooth Settings on the iPhone and turn BT ON.
    Start TT unit and Go to Bluetooth and click Add a Phone
    Tap GO620 when it appears in Bluetooth on your Phone and pair the units.

    You should now have a good Bluetooth connection and received Traffic etc vis BT when out of Wifi range.

    You must have Personal Hotspot on then connected via Bluetooth but you will never be asked for the Password. If you turn Personal hotspot Off you will lose the BT connection.

    Regarding the My Drive App you can still use that for creating and sending Routes etc .

    Doug
  • YamFazManYamFazMan Posts: 19,253
    Superusers
    edited April 11
    Hi
    @ozpom04
    Welcome to the site....
    Are you using an iPhone + The Tomtom MyDrive App ???
    There's an unresolved problem with the Apple iPhone iOS 13 & 14 the MyDrive App and the advanced Smartphone features....
    If you can live without the bells & whistles of the MyDrive App...
    Just use a straight simple Bluetooth Connection....
    Traffic will still work... MyDrive Route planning will work
    the only thing that does not work will be smartphone Text Messaging features....
    Here... https://discussions.tomtom.com/en/discussion/comment/1729911/#Comment_1729911

    Stay Safe... ATB YFM
  • ozpom04ozpom04 Posts: 5 [Apprentice Traveler]
    Thanks for the suggestions guys, which I tried but the traffic & other services still comes up as not connected! Phone and messages are connected but I don't use them as the car picks them up on CarPlay.

    Surely with my HotSpot on on the device, it will receive traffic updates anyway via WiFi so why would it need to be on for BT to connect? - thing is I don't like to leave my hotspot running.

    I'm really disgusted with TomTom for being so slack AND not notifying customers about the issue - I only found it wasn't connecting when I got stuck in a traffic jam on the way to a hospital. Same happened with my previous device a few years back when the 2G network was shut down in Australia - NO notification from TomTom, got stuck in traffic as no live updates and they wouldn't refund several months of my subscription, just hopeless!!! Now you cant even phone support - if they don't get this sorted asap I'll get another SatNav and definitely not a TomTom.

    Very dissatisfied customer after more than 10 years of using their devices - no recommendations from me.
  • DougLapDougLap Posts: 7,731
    Superuser
    Hi @ozpom04

    I do know the technical reason why having the Personal Hotspot option switched On in settings is needed but if you don’t have it on the Bluetooth link will not work.

    Please note that at no time did I suggest that you login into your Personal Hotspot in the GO629’s Wifi facility. If you follow what I described you will not be asked for the PH password nor will it show as connected in the devices Wifi. However if you pair the device, with PH set to On in Settings, you should get traffic but will lose the Bluetooth connection if you turn Off PH or don’t have it on when you turn your device on.

    Doug
  • kieronkieron Posts: 458
    Superusers
    edited April 11
    Hi there ozpom04 -

    Please try this to see if it helps - go into your iPhone settings, then make sure:

    1. WiFi is Off. (This is important)

    2. Bluetooth is On.

    3. Mobile Data slider switch is to the right and showing a green colour (On).

    4. Personal Hotspot settings “Allow others to Join” will now need to be set for “Bluetooth and USB Only” and NOT “Turn on WiFi’.


  • ozpom04ozpom04 Posts: 5 [Apprentice Traveler]
    Hi,
    Yes Doug, I agree that you didn't say to logon to HS WiFi but as I had already connected the Go to my HS it had remembered the password.

    I'll give Kieron's suggestion a go as I can see that with WiFi off the iphone its going to limit the available connections, but, if you subsequently turn WiFi back on will the WiFi connection to the GO reconnect and cut off the BT?

    Any suggestions as to when TomTom is likely to fix the problem as its been a while since it started - you cant blame Apple for the problem as connections to other BT devices still work OK.
  • ozpom04ozpom04 Posts: 5 [Apprentice Traveler]
    This is ridiculous, I tried the different suggestions, the iPhone shows as connected to TomTom and TomTom shows as connected to my iPhone BUT Data for Traffic & Other Services shows 'unable to connect' but Hands Free Calls are available.

    I shouldn't have to wast time trying to fix something that I shouldn't have to, I paid for services when I bought the device and I'm NOT getting what I have paid for!!!! SO, IS TomTom fixing the issue or what??????????????? This discussion group is obviously monitored by the company so why isn't there any comments from TomTom ????????? Maybe you dont care about Australian customers - TOMTOM ARE YOU DOING ANYTHING TO FIX THIS ISSUE????????????????????????????????????????????????????????????????????????????????
  • YamFazManYamFazMan Posts: 19,253
    Superusers
    edited April 15
    Hi
    @ozpom04
    Are you using an iPhone + The Tomtom MyDrive App ???
    There's an unresolved problem with the Apple iPhone iOS 13 & 14 the MyDrive App and the advanced Smartphone features....
    If you can live without the bells & whistles of the MyDrive App...
    Just use a straight simple Bluetooth Connection....
    Traffic will still work... MyDrive Route planning will work
    the only thing that does not work will be smartphone Text Messaging features....
    Here... https://discussions.tomtom.com/en/discussion/comment/1729911/#Comment_1729911

    Stay Safe... ATB YFM
  • DougLapDougLap Posts: 7,731
    Superuser
    Hi @ozpom04

    I have flagged this to @VikramK or @lampard to review your settings on the Tomtom Servers in case they need adjusting.

    Look back here later to see what they have to say.

    Doug
  • MrEZ3MrEZ3 Posts: 6 [Apprentice Traveler]
    Nothing seems to be working. Tried all the steps but still no traffic or speed cameras!!!!
  • doctormstein1doctormstein1 Posts: 138 [Renowned Trailblazer]
    I couldn't connect for the longest time. it was on and off. Finally, I deleted the my drive app totallly and readded it with the right permissions and finally it works great
Sign In or Register to comment.

Who's Online in this Category1

alfy80
alfy80