Amigo not working in background — TomTom Community

Amigo not working in background

mattpatmanmattpatman Posts: 3 [Apprentice Traveler]
Hello. I love the Tom Tom amigo app, it helps me be a better driver with its speed alerts, however recently it has not been working in the background. So I am happily driving along no issues then I’ll get a call and by the time I’m off the call the app will have forgotten where I was navigating too and seems to have forgotten where I am, when I navigate back to the app it is like I am starting it up again as it takes a second or two to locate where I am. It’s not just calls, if I pull over to read an email or message, it seems to stop working in the background. I have not changed any settings recently to my knowledge. Could someone help with this?

Answers

  • lampardlampard Posts: 5,314 Moderator
    Hi @mattpatman

    Welcome to the Community! In some cases, the routing sometimes fails to complete when there is a sudden network change or when there are network issues (Or when you move from the Sim network provider to Wifi).

    This is mostly seen in iOS 12 and upwards. Can you provide us with the phone model, iOS version, and App version installed on your phone?

    Best, lampard
  • mattpatmanmattpatman Posts: 3 [Apprentice Traveler]
    Hi Lampard. It’s an iPhone XR, iOS 14.4.2, app version 7.488.0 (8902), navigation engine version 12.1.0
    Hopefully this is the info you need to help me fix it as it was the perfect driving companion app until it started playing up!
    Thanks, Matt.
  • mattpatmanmattpatman Posts: 3 [Apprentice Traveler]
    I do have a business line installed, an e-sim with its own data plan. My phone is set to use the primary line for data, not sure if this could be an issue? But again it’s been this way for nearly a year and the issue has only started in the last month or so
  • _Jack__Jack_ Posts: 1 [New Traveler]
    I have an IPhone 12 with 14.4.2 and have the same problem... even if geolocation is set in “always” in settings
  • lampardlampard Posts: 5,314 Moderator
    Thanks, @mattpatman & @_Jack_ !

    I'll check with my team and let you know if there's any update.

    Best, lampard
  • theBurntheBurn Posts: 1 [New Seeker]
    edited May 12
    Any news on this topic?
    Background Mode is still not working!

    iPhone X, 14.5.1
    AmiGO 8.17.0

    If you want, you can send me a TestFlight invite - as Manuela from TomTom in the AppStore reviews answered that it works in her Beta…e1iy4m3yrm50.png

    Thanks
Sign In or Register to comment.

Who's Online in this Category0