Tomtom Go 5200 cannot connect to MyDrive Connect — TomTom Community

Tomtom Go 5200 cannot connect to MyDrive Connect

My tomtom go 5200 device is asking me to insert a card and i cannot access the menu or settings of the device. When i connect it to MyDrive connect via USB cable, the mydrive connect sasys " On the device, Go to Settings in the main Menu."

I dont have any access to the settings or the main menu or whatever. It just blinks "instert card" and nothing else. How can i connect the device to the computer when it asks me to go to the menu which i dont have access to ? i tried hard reset and soft reset, neither of it works.

Thanks

Answers

  • rider1riderrider1rider Posts: 563 [Revered Pioneer]
    do you have memory card in device
  • LiubakaLiubaka Posts: 5 [New Seeker]
    Yes i have Sd card inserted but its blank. The device is asking me to format it and i did that already. However there is no way i can access the Menu of the gps so i can go to settings and be able to connect it to the drive connect software and update,buy ... maps .. etc
  • DougLapDougLap Posts: 7,621
    Superuser
    Hi @Liubaka

    The Go 5200 comes with World Maps so you do not need to buy them as any Car based Map that TT make are available for download free via Add a Map in Settings/Maps.

    What size is the SD card you have inserted?

    You don’t need to be connected to a PC if you have reasonable Wifi as the device when connected to it can add maps and update them without a PC.

    Doug
  • LiubakaLiubaka Posts: 5 [New Seeker]
    I cannot go to Add Map in Settings. The device has only one message which says "add a map" , after i click on it the "Menu" button appears for less than half a second and it goes away, i try to click on it but it doest work so i cannot access the device menu/settings or whatever. It just pop ups the same mesage "add a map" and nothing else. Even after hard reset it says the same.


    When i disconnect the usb cable from my pc it says there is an update 312mb but in order to apply that, i also need to click on it at the bottom of my screen, which disappears the same as the menu button for less than half a second and that scree/menu cannot be entered either.

    let me show u pictures

    imsyiwte1nrc.png
    u can see here it says insert map in danish language


    mtkje6uo12yc.png

    here the menu button appears but it goes away in 0.0001 seconds and cannot be entered in anyway






  • LiubakaLiubaka Posts: 5 [New Seeker]
    somehow i managed to click the update menu which appears at the bottom for a fraction of a second and its now updated but i still cannot access the menu. keeps saying insert map. i guess the admin will have to add the device into my account manually so i can then connect to pc and install the maps from there
  • Willy875Willy875 Posts: 849 [Revered Pioneer]
    Hello Try to do a reset

    MyDrive Connect (MDC) opens and does not offer updates.
    For WiFi devices connected via USB, MDC only acts as an intermediary for the provision of the internet connection.
  • LiubakaLiubaka Posts: 5 [New Seeker]
    when i make soft reset or hard reset the device loads and i can click and access the menu for about 2-3 seconds, then again it pops up insert map, and then i cannot longer access the menu of the device. i connect it to internet but nothing happens as i need to go into the menu first which i cannot access :)
  • YamFazManYamFazMan Posts: 19,076
    Superusers
    edited April 5
    Hi
    @Liubaka
    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2Hrs….
    (Preferably using something like a Smartphone Charger using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....
    __________________________

    Tomtom devices need at least one Map installed before they will Boot-up....
    TomTom FAQ... No maps available (Wi-Fi® devices)
    Here... https://help.tomtom.com/hc/en-gb/articles/360013958699-No-maps-available-Wi-Fi-devices-

    Tomtom FAQ... No maps available (MyDrive Connect)
    See... https://help.tomtom.com/hc/en-gb/articles/360013900620-No-maps-available-MyDrive-Connect-

    Stay Safe... ATB YFM
Sign In or Register to comment.

Who's Online in this Category0