no sound from unit tomtom go 620

turnpower
turnpower Registered Users Posts: 3
New Seeker
edited December 2021 in Devices using Wi-Fi®
the volume is set high and not in mute mode have serena selected and all sounds and warnings set to on-was working fine than the next day just stopped its been like this for two months-every so often will say one or two words but even that has stopped now-i have tried soft and hard resets with no joy and even the unit is slowing down-brought this unit from tomtom about two years ago and was working fine and than this problem started-the unit is in mint condition with no damage -can any one help me out thanks-my unit is a tomtom go 620

Answers

  • VikramK
    VikramK Administrators Posts: 14,283
    Moderator
    edited April 2021
    Hi @turnpower
    Have you tried a factory reset already?
    Main menu- Settings-System-Reset

    To avoid losing your stored favourites on the device you can create a backup using MyDrive..

    See user guide

    If a factory reset is already tried then I would recommend a recovery mode, see steps in the video below-



    Regards, Vikram
  • turnpower
    turnpower Registered Users Posts: 3
    New Seeker
    thanks for your help it went through recover mode twice and than a software up date but still no voice instruction or screen button tap sound
  • VikramK
    VikramK Administrators Posts: 14,283
    Moderator
    Thanks for trying @turnpower
    This will require some further investigation. So I would recommend that you contact and report this to our customer service team.

    Regards, Vikram