Rider 550 not working at all anymore — TomTom Community

Rider 550 not working at all anymore

MattiMucMattiMuc Posts: 3 [Apprentice Seeker]
Hello everybody,

so today I decided to get my Rider 550 ready for the new season as it has been in the drawer since November because I figured I will probably have to make a bunch of updates etc. .

These are the problems I have at the moment:

It will not connect to my WiFi. It says it is not in range. I can assure you it is. I also already have read through various threads with this problem and tried out a bunch of things of which none have worked so far.

It will not connect to my phone / MyDrive App. It also says it is out of range. I can add a "new" Device with the app by scanning the QR-Code. It briefly says it has successfully paired but then just goes back to the screen where it says the Rider is out of range.

It will not connect to my PC / MyDrive Connect for Win10 (with the original Micro-USB cable). The Rider is charging however and I can get a connection with a different device and the same cable. So cable should not be the issue. I have also tried out other cables. Still wont connect to my PC

I did soft resets. Still have the same problems.

I then did a hard reset. I still have the same problems.

Thanks in advance for your help!
Tagged:

Answers

  • DougLapDougLap Posts: 7,589
    Superuser
    edited March 21
    Hi @MattiMuc

    Have you ensured it is fully charged. If not then I suggest that using the same USB cable that you then connect that to an Apple or similar Phone mains charger plug and leave for at least 2 hours. This offers a better charge than when the unit is connected to a PC's USB socket.

    The inbuilt batteries do not like long periods with no recharging and will ultimately fail if allowed to go flat for long or frequently.

    Doug
  • MattiMucMattiMuc Posts: 3 [Apprentice Seeker]
    Hi @DougLap, I had it charging for about 30 minutes. So no it is not fully charged.
    Thanks for your tip, I will try that and report later if that made a difference.

    Cheers
  • MattiMucMattiMuc Posts: 3 [Apprentice Seeker]
    [UPDATE]
    As @DougLap suggested I fully charged my device.
    WIFI [SOLVED]:
    At first I still had the same issues. I then realized that the Rider can find my Wifi but for some reason only gets 0.0.0.0 as its IP Adress. I removed the wifi from the device and rebooted my router. I was then able to fully connect to my wifi and install all updates.

    MyDrive App (Google Pixel 3XL) [SOLVED]:
    Still was not able to connect. Then realized that my Fitbit Charge 4 is also connected to my Phone :# Disconnected Fitbit and was immediately able to connect to the MyDrive App.

    MyDrive Connect (Win10)
    I still have issues. The Rider is charging, but the the Win10 program can't see it. I have tried various USB Ports 2.0 and 3.0 on my PC as well as over 4 different Micro-USB cables including the original one.
    It also does not pick up in my Windows device manager.

    Thanks and cheers
Sign In or Register to comment.

Who's Online in this Category0