My GO Premium X does not connect to GPRS and thus no traffic information

Harmen
Harmen Registered Users Posts: 4
New Seeker
edited December 2021 in Devices using Wi-Fi®
Hi,

I have a Go Premium X (from May 2019).

After the most recent software update, the TomTom no longer connects via GPRS to Traffic Information.
I checked the self-service site, and was redirected to a video.
I executed all of the steps in that video (sharing = on, GPS = OK, Batery = OK, NL supports traffic, not connected to phone - due to inbuild GPRS, factory settings, waiting an hour); no positive outcome.

Any tips?

Regards,
Harmen
Tagged:

Answers

  • DougLap
    DougLap Posts: 10,029
    Superuser
    Hi @Harmen

    Go to the My Drive Website and log into your account and check that all your My Places, routes etc are saved there. If they are then do a Factory Reset.

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    Your MyPlaces etc will sync back to the unit from you account when it logs into the account.

    By the way it will show GPRS as disconnected if the unit is attached to the Wifi.

    Doug
  • YamFazMan
    YamFazMan Posts: 21,133
     Superuser
    Hi
    @Harmen
    Welcome to the site......
    Tap 4Dot (.... Menu) → Setting → System → About…
    Scroll down to Data Connection & GPRS Status....
    What does the device report...???
    Is the GPRS Status... Connected ???
    Are the following categories displaying any Numbers ???
    MCC/MNC
    IMEI
    SIM ID
    GPRS Model

    Stay Safe... ATB YFM
  • Harmen
    Harmen Registered Users Posts: 4
    New Seeker
    Overview 1:
    > Traffic: No internet
    > Mydrive: No internet
    > Bluetooth: Setup phone
    > WIFI: setup wifi

    Overview 2:
    > Dataverbinding: Geen
    > GPRS status: no connection
    > GPRS Model: 16.01.202
  • Harmen
    Harmen Registered Users Posts: 4
    New Seeker
    Hi @DougLap,

    Thanks for the suggestion - was also in the DIY video.

    I already reset to factory settings twice today, and this did not resolve the issue.
    Even including the "press the ON/Off switch for 45 sec iso selecting a country from the list".


    Any other thoughts?

    Regards,
    Harmen
  • DougLap
    DougLap Posts: 10,029
    Superuser
    Hi @Harmen

    When you go to Settings/System/About what does it say agains Traffic and Cameras.

    Doug
  • Harmen
    Harmen Registered Users Posts: 4
    New Seeker
    Hi @DougLap,

    Both are greyed out.

    Regards,
    Harmen
  • DougLap
    DougLap Posts: 10,029
    Superuser
    Hi @Harman

    Let us see what @VikramK has to say after he has had the chance to look at your units settings and restored them to Lifetime if appropriate. Look back here tomorrow.

    Doug
  • VikramK
    VikramK Administrators Posts: 14,283
    Moderator
    Hi @Harmen
    Could be related to a SIM issue. I would recommend that you get in touch with our customer service and let them review the status.
    Helpful link- https://help.tomtom.com/hc/en-gb/articles/360015568919/

    Regards, Vikram
  • DougLap
    DougLap Posts: 10,029
    Superuser
    Hi @Harmen

    Re getting on to Customer Support .

    Try the following:-

    Tap Support at the top of this page
    Sign in Top Right of next Page. (you have to do this)
    When signed in Tap Contact Us bottom right
    Help Box appears and after a few seconds Get in Touch also appears
    Tap Get in Touch
    You are now offered Chat or Email. If Chat is closed it will tell you the hours that it will be available.

    Chat is busy you may have to try a few times.

    If the above dos not work try another Web Browser.

    Doug
  • Keith G
    Keith G Registered Users Posts: 2
    New Traveler
    I had the same problem but mine was connected via USB to a PC unplugged it and up it came,
  • Kim9530
    Kim9530 Registered Users Posts: 2
    New Seeker
    Hello all,

    I’m having the exact same problem. Did you find a solution?
  • Willy875
    Willy875 Registered Users Posts: 6,498
    Revered Voyager
    Hi

    You are in Belgium there is always a problem with live services in Belgium.
  • Kim9530
    Kim9530 Registered Users Posts: 2
    New Seeker
    You live in Belgium too?