Watch not syncing since it was updated to latest version since some time now.

Sharath9441
Sharath9441 Registered Users Posts: 2
New Seeker
edited January 24 in TomTom Sports
I have a Tomtom adventurer with software version v1.7.64. It used to sync well with the phone however since its updated (since more than a year now) it is not able to connect to mobile app. During paring of watch with phone watch shows bluetooth code/pin but screen quickly reverts back to pair with phone screen. This was not so in the older software version. Request if my account could be reverted back to the older stable version so that I could reset my watch on the PC.

Answers

  • tfarabaugh
    tfarabaugh Posts: 16,936
    Superuser
    You should try to reset the phone connection following these steps. First need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again and remove the TomTom_MySports folder from the internal storage of the watch (plug it into a computer and you will see it as a hard drive and can delete it there). The steps are: uninstall the app, remove or forget the watch from the phone's BT menu, factory reset the watch, reinstall the app, select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.
  • Sharath9441
    Sharath9441 Registered Users Posts: 2
    New Seeker
    Tried all this but did not work. There is no folder "TomTom_MySports" in the watch when I connect it to the PC. Watch syncs well with desktop app though. Initial pairing not happening with Phone. Please help. I read somewhere that reverting it to the older versions solved the problem.
  • tfarabaugh
    tfarabaugh Posts: 16,936
    Superuser
    Tried all this but did not work. There is no folder "TomTom_MySports" in the watch when I connect it to the PC. Watch syncs well with desktop app though. Initial pairing not happening with Phone. Please help. I read somewhere that reverting it to the older versions solved the problem.

    There is no way to revert to an older version and it did bot help this anyway. TT stopped rollbacks years ago (they went out of business over 3 years ago). A factory reset will put you on the last stable firmware. Other than that there is no solution, the steps given above have worked for everyone else. You can reach out to TT Support directly (this is a user forum) by chat or email (there is no phone support) but they will tell you just what I did. These watches are obsolete dead products and are minimally supported so it may be time to move on to another watch if you can't fix it or can't live with syncing by computer (which is actually faster and more stable).