Old XL 340, lost TTS after 10.65 update and no backup — TomTom Community

Old XL 340, lost TTS after 10.65 update and no backup

Subject says it all, updated old device to 1065 and in the middle it stopped and said I requested an Abort (which I did not). Restarted the update and appeared to complete OK. However, on startup there was an error that Selected voice not available. The only voice that worked was a weird Chinese voice I'd never seen before. Samantha was listed but was grayed out, and could not be selected. And it seems Samantha is the wrong TTS voice for this unit. So went to Manage Device, deleted map and all voices. Rebooted and redownloaded map and the non-TTS voices with Home. Afterwards no Samantha and there was a different weird Chinese voice "Lei" that I didn't ask for. Everything seems to work now, but no Susan TTS! Stupidly did not take a backup.

From searching these forums, maybe restoring the Susan data under LoquendoTTS might work. But this does not seem to be available. The Add Voices area of Home is grayed out -- as device is not supported? Seems it should be possible to download stuff that was originally made available! Or is there an alternate way to obtain these files? Also don't really remember that "Susan" was the TTS voice, but seems that is the right one for an XL340 with Loquendo.

Thing is, have updated this device occasionally over the years and never had an issue (maybe just lucky) so neglected to do the backup. These old devices literally take hours to do a backup, so easy to get lazy. Old PC has limited disk, so did not save old TomTom backups either.

Maybe "it is what it is" -- but if there is a simple (or not so simple) solution, would be great to know!

Answers

  • gotomtom94022gotomtom94022 Posts: 2 [Apprentice Seeker]
    Thanks for the super responsive follow up. Had to work on this after work, but dropped this into the device drive and it works! Has a couple of extra voices from original too, Kate (UK) is a refreshing change -- female announcers seem to cut through traffic noise better.

    Turns out discovered a workaround with TomTom Home 2.21.1.147 (Windows) -- registered device and checked the "login when connected" box. Disconnected the device, quit and restarted. TomTom Home then launches as logged out and lets you navigate to Add Voices. At that point, a dialog pops up asking you to connect your device. When you do so, it auto-logins when connected and shows voices that can be added -- works for both conventional and TTS voices. Just select and Add to install.

    Now only Susan and Simon are shown for USA with this workaround -- but this may be an alternative for folks who are not confident directly modifying the file system of the device. Like to ensure a clean folder, should rename the existing LoquendoTTS to something like LoquendoTTS-old and then drop in the ZIP contents as a pristine folder. But really, it's not hard to unpack the ZIP and put the folder onto the device drive.

    As an aside, tried to get rid of the spurious Chinese voice by deleting all voices on the device and restoring from the PC -- but the "Lei" Chinese voice remains (and it does work). Not a big deal, just odd. There is no "Lei" voice shown in Home, either on the device or on the computer.

    At any rate, will be careful to keep a backup around going forward. And this may be the last update I attempt anyway. The roads in our area don't change that much, and can buy much more recent TomTom/Garmin/Magellan(?) devices on eBay for $50 or less. These old devices are sluggish and a hassle to keep current. Still this device works as well as when new, and there's something to be said for lifetime maps/traffic *without* being dependent on a smartphone connection. All good for now, but we'll have to see how it goes...
Sign In or Register to comment.

Who's Online in this Category0