Go Professional 620 stuck on no map available — TomTom Community

Go Professional 620 stuck on no map available

I have opted to start a new discussion on this as I've had no replies for 24 hours. So the original issue was an outdated map on a brand new unit with no option to update. @VikramK solved this but once I downloaded the map over Wi-Fi it showed as no map available. If I then press the add map option their is no map to add and the device is currently stuck on these 2 screens only. Have turned off and on and done a reset but no difference. As it was only a new unit it had only been on Wi-Fi and not set up on my drive connect which i now can't do as i have no access to the device screen. This has been ongoing since last week and I am now left with a non working unit which I require for work in 24 hours time :'( Any help would be much appreciated.

Comments

  • DougLapDougLap Posts: 8,867
    Superuser
    Hi @GavinMac21

    This is the process normally used to resolve the No Maps Found situation

    https://discussions.tomtom.com/en/discussion/1041654/no-maps-available-wi-fi-devices#latest

    If this is not working for you if you have the latest version of My Drive connect on your PC you are now able to get past the Do it the Easy Way splash screen and see more details. Can you try that to see if you can allocate a map.

    If not then I suspect that you will need @VikramK to do his magic and get a map to be available.

    Doug
  • VikramKVikramK Posts: 12,711 Moderator
    Hi @GavinMac21

    Welcome to the community!
    Could you send me the serial number of your device through a private message, please?

    Thanks, Vikram
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    Hi @VikramK apologies for not replying. I have since contacted via chat and after some trying was advised to return the unit and order a replacement. Finally received another unit late last week which has done the identical thing. Contacted via chat again after much trying no progress. Chat had then closed for the weekend so used email for a while until they finished work. Still no result so I will have to wait until they open again next week. So am currently left with a 2nd unusable device.
Sign In or Register to comment.

Who's Online in this Category0