GO 500 stuck in wanting to connect to computer — TomTom Community

GO 500 stuck in wanting to connect to computer

when i turn on the go 500 in the car, it shows wanting to connect to computer and then hanging.

Answers

  • VikramKVikramK Posts: 11,104 Moderator
    Hi @emmyy
    It seems the device is stuck in a recovery mode..
    Could you try the steps advised in the video below-



    Thanks, Vikram
  • emmyyemmyy Posts: 7 [Apprentice Seeker]
    i Vikram, Thanks for your advice. before i go and do all that, i want you to know that the go500 connects to the computer and mydriveconnect without any problem. It is when i take it down to my car that it still wants to connect to the pc.
  • emmyyemmyy Posts: 7 [Apprentice Seeker]
    i went through the process but Mydriveconnect appears saying NO INTERNET CONNECTION which is not true because i am on the internet. i've uninstalled and reinstalled mydrive connect. its strange.
  • VikramKVikramK Posts: 11,104 Moderator
    Thanks for elaborating on the issue further.
    Sorry I got it confused with a different issue.

    It's asking you to connect it to the computer probably because you are trying to charge the device through a USB slot rather than a CLA.

    Thanks, Vikram
  • emmyyemmyy Posts: 7 [Apprentice Seeker]
    what is a CLA
  • emmyyemmyy Posts: 7 [Apprentice Seeker]
    myconnect says NO INTERNET CONNECTION.
    Can anyone help please. i am constantly unable to go on the internet
  • emmyyemmyy Posts: 7 [Apprentice Seeker]
    with tomtom mydriveconnect. i HAVE internet connection. it is just the stupid tomtom that thinks i dont
  • VikramKVikramK Posts: 11,104 Moderator
    edited February 19
    emmyy wrote: »
    what is a CLA

    l8u6lp2f8a6v.png
    CLA- Cigarette Lighter Adapter
    emmyy wrote: »
    myconnect says NO INTERNET CONNECTION.
    Can anyone help please. i am constantly unable to go on the internet

    It could probably be related to connectivity blocked via Anti-virus/Firewall software or the network not allowing access to MyDrive Connect.

    See this article- https://help.tomtom.com/hc/en-us/articles/360014520440

    If the configuration doesn't help then I would recommend that you try updating the device on a different computer/different network.

    Thanks, Vikram

Sign In or Register to comment.

Who's Online in this Category0