Go5200 traffic not working

Accuway123
Accuway123 Registered Users Posts: 5
New Seeker
edited December 2021 in Devices using Wi-Fi®
Hi
I can no longer receive lifetime traffic updates via built in sim. I have connected using phone data wifi hotspot and it works ok.

Best Answer

  • Accuway123
    Accuway123 Registered Users Posts: 5
    New Seeker
    Answer ✓
    @DougLap
    Sorry about that, I asked question in another part of forum, then found the welcome and support page and thought I should have posted there to get response, lesson learned

Answers

  • DougLap
    DougLap Posts: 10,168
    Superuser
    Hi @Accuway123

    This is the third time you have posted this question within the last 30 minutes. This forum is for users so you need to wait for another user to be on the forum and pick up your question.

    Firstly you could try a Soft Reset. Ie turn the unit on then when working press and hold the On / Off button until you hear the drumroll sound.

    If the above does not work then do the following factory reset

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    Before you do the factory reset go to the Tomtom MyDrive website and check that all you My Places and Routes are saved there so that they will be restored back on the unit after the Factory Reset.

    There have been instances where the inbuilt sim contacts have become corroded. The sim is under the little label in the bottom and comes out like a memory card. At your own risk you could try removing that and carefully cleaning the contacts then pushing it in and out of its slot a few times. If you do this it will not be covered by warrantee any longer if it is covered at the moment.

    Finally you could contact Customer Support to see if they can check the sim for you. There is no phone line contact during the current situation so you need to contact them via chat.

    Doug
  • Accuway123
    Accuway123 Registered Users Posts: 5
    New Seeker
    Answer ✓
    @DougLap
    Sorry about that, I asked question in another part of forum, then found the welcome and support page and thought I should have posted there to get response, lesson learned
  • Accuway123
    Accuway123 Registered Users Posts: 5
    New Seeker
    @DougLap
    Device is 2 years old so no warranty, tried reset still no good, will give the sim a try
    Cheers
  • YamFazMan
    YamFazMan UKPosts: 21,480
     Superuser
    edited February 2021
    Hi
    @Accuway123
    Check... Tap 4Dot (.... Menu) --> Setting --> System --> About....
    Scroll down what does 'Data Connection'
    Report as connected ???

    ATB YFM
  • Accuway123
    Accuway123 Registered Users Posts: 5
    New Seeker
    Sorted
    Removed label, Carefully removed sim by edges, cleaned sim and contacts with IPA cleaner. Refitted all good
    Thanks for your help
  • DougLap
    DougLap Posts: 10,168
    Superuser
    Hi @Accuway123

    Glad you are sorted.

    Doug