Current map version for Go Professional 620 — TomTom Community

Current map version for Go Professional 620

I have just upgraded to a Go Professional 620. Everything has connected as it should and the unit itself is running fine. My issue is the installed map is out of date but their are no available updates showing. The installed map is Oceania Truck V1035.9691 released 7/2019. I have tried a soft reset but to no avail. Can anyone offer any advice on this please.

Answers

  • DougLapDougLap Posts: 8,823
    Superuser
    Hi @GavinMac21

    Hopefully @VikramK or @lampard will pick this up and review and adjust if appropriate your units settings on the TT servers. Look back here later to see what they have to say.

    Doug
  • YamFazManYamFazMan Posts: 20,053
    Superusers
    Hi
    @GavinMac21
    Welcome to the site....
    The restrictions as a result of the COVID-19, Social Distancing and people working from home, are probably delaying the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up and check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • VikramKVikramK Posts: 12,678 Moderator
    Hi @GavinMac21 Welcome to the community!
    I have asked the team to fix the services for your TomTom, please do a soft reset and check for updates.


    Regards, Vikram
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    Hi @VikramK I have just tried that but no difference.
  • VikramKVikramK Posts: 12,678 Moderator
    @GavinMac21
    What do you see on the device screen when you go to -
    Main menu-Settings-Updates and New items?

    Thanks, Vikram
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    @VikramK
    Hi. I have just tried it again now and it says it is up to date
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    @VikramK

    This has gone from bad to worse. It did show a map available for update which I did also speed cameras updated so that appears to be working. Now it is saying no map available and I can't add a map. It is showing as installed on my drive. As a commercial driver I'm now left without a functioning device which is most inconvenient. Could this please have some urgency attached to it as I need it for work tomorrow.

    Cheers
  • DougLapDougLap Posts: 8,823
    Superuser
    Hi @GavinMac21

    Tap 3 bar menu top left of this page
    Tap Discussions Home top left
    Scroll down and tap Videos
    Tap No 26 No maps found Wifi

    Hope that sorts it

    Doug
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    @DougLap

    I have tried that but it doesn't show any maps to add. I have restored the unit, restarted, reset and all to no avail. Have also tried my drive connect and WiFi but nothing.
  • DougLapDougLap Posts: 8,823
    Superuser
    Hi @GavinMac21

    Okay let’s see if @VikramK can sort out the map becoming available. Look back here later to see what he had to say.

    Doug
  • VikramKVikramK Posts: 12,678 Moderator
    Hi @GavinMac21
    My team has added a script in the backend that will remove the installed map. Just connect the device using MyDrive Connect or WiFi and the jobs will process automatically.

    Once just do a soft reset and check for a fresh map download.

    Thanks, Vikram
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    @VikramK
    Ok so did that and downloaded another map but still have the exact same problem
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    Hi guys
    While I appreciate the assistance so far this is a brand new unit that has gone from srm8 functional to completely useless. To make matters worse I no longer have my previous unit. Some urgent assistance would be hugely appreciated.
  • GavinMac21GavinMac21 Posts: 10 [Apprentice Seeker]
    08k1g2hfkeu2.jpg
    [img]https://us.v-cdn.net/6031227/uploads/editor/ji/qty7z kgmd9ht.jpg[/img]
    @VikramK
    I have tried what you suggested earlier but I'm still stuck with the attached screens. Click on add map but the next screen doesn't give an option to choose a map at all. I really need this sorted before Sunday when I start work again. Unfortunately we are in opposing time zones which doesn't help but it would be much appreciated if this could be resolved before your weekend.
    Cheers
Sign In or Register to comment.

Who's Online in this Category0